Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

How do I disable Game Booster Notifications?

(Topic created on: 21-08-2021 02:51 PM)
37114 Views
Members_bfF62Fw
Explorer
Options

Every time I play a game app on my S10 phone, a notification appears in the notification area from Game Booster. If I press on it, there's no option to disable it. If I choose 'notification settings' I'm told that it was Game Booster that showed the notification but any attempt to disable it from showing notifications is not allowed. The enable/disable slider/button is deactivated. Why am I not allowed to stop this thing (whatever it is) from spamming me with notifications that I'm not interested in? That's the behaviour of malware rather than something useful.

I just want it to stop.

I've googled this a bit and some people suggest disabling the 'game launcher' but that makes no difference. I suspect that's a different thing.

I understand that Samsung think they want to help us with the software they pre-install, but everything should be able to be turned off if the user wants. Microsoft was forced to do it on Windows. Apple are being pressured. Do we need to start a movement to get the EU to ban Samsung from forcing us to use things we don't want to also?

I fully expect this to get no official Samsung staff member to comment on this.

2021-08-21 15.44.10.png2021-08-21 15.47.04.png2021-08-21 15.46.54.png

---S24 256GB---

1 Solution


Accepted Solutions
Solution
AndrewL
Moderator
Moderator
Options

@Members_bfF62Fw: Try heading to Settings > Apps > Tap the 3 lines to the right of 'Your Apps' > Show System Apps > Game Booster > Scroll down > Appear On Top > Allow Permission, and toggle this on. Let me know if this helps. 

View solution in context

15 REPLIES 15
Members_bfF62Fw
Explorer
Options

Game launcher has been disabled for months. It doesn't affect game booster. Maybe technically it disables game booster from actively doing anything, but it certainly doesn't disable the booster notifications.

---S24 256GB---
Solution
AndrewL
Moderator
Moderator
Options

@Members_bfF62Fw: Try heading to Settings > Apps > Tap the 3 lines to the right of 'Your Apps' > Show System Apps > Game Booster > Scroll down > Appear On Top > Allow Permission, and toggle this on. Let me know if this helps. 

Kenneth-071
Navigator
Options

A temporary fix would be to force close the Game Booster app, if the app isn't running it cannot send notifications. Your only other option would be to disable the Game Booster app via ADB as it cannot be disabled from the phone itself.

If you're interested in the ADB route, I already explained it in this topic here. Just replace the package name mentioned in my post with com.samsung.android.game.gametools.

Members_bfF62Fw
Explorer
Options

Thanks. Both those options seem good, but AndrewL's suggestion did the trick 😎😍

---S24 256GB---
Members_bfF62Fw
Explorer
Options

Thanks Andrew, that solved it for me. I can't believe I've let it bug me for the last year without trying harder. A few times I've googled it and been disappointed with the results. Hopefully this one rises up the google rankings as it is the answer. It's also somewhere I'd never have 'just found' by poking around. I'll be using that 3-lines-to-the-right-of-'Your Apps' more often now I'm sure 😁

---S24 256GB---
ED28
First Poster
Options

Andrew, would you please translate these instructions to a Galaxy S21 5G with Android 11? I've tried everything I can think of, and if the switch isn't greyed out, the other settings I've tried changing have not worked.

Thanks.

Ed28

0 Likes
PeterinFtl
First Poster
Options

It's counter-intuitive (for me, anyway) but it does work on my A10e. Thank you!

0 Likes
antiforcedBLOATWARE
Apprentice
Options

ALLOWING PERMISSION FOR GAME BOOSTER TO SHOW ON TOP DOES NOT PREVENT IT FROM TURNING ITSELF BACK ON AFTER YOU HAVE TURNED IT OFF - THEREBY PREVENTING YOU FROM LOGGING INTO GAMES. WRONG ANSWER! WE WANT TO DISABLE GAME BOOSTER!

antiforcedBLOATWARE
Apprentice
Options

NO IT DOES NOT. INACCURATE INFO.