Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Receiving every incoming calls as private number..

(Topic created on: 28-08-2021 11:54 AM)
Foyez
First Poster
Options
Galaxy S9 Series
All incoming call coming as Private Number..Every single call.. outgoing is fine..Cant detect who called if i miss a calll..Anyone got this issue? plz help
0 Likes
3 REPLIES 3
Ventor
Samsung Maker ★
Options
Galaxy S9 Series

@Foyez Hello, from the Phone app settings / Other call settings, activate Show caller info.

0 Likes
AndrewL
Moderator
Moderator
Options
Galaxy S9 Series

@Foyez: This shouldn't be the case for any saved contacts, however for non-contacts please head to the Phone app > Tap the 3 dots in the top right > Settings > Caller ID and Spam Protection > On. 

0 Likes
Wavytallman
Journeyman
Options
Galaxy S9 Series
I'm having same issue and my caller id and spam protection is on running with Samsung Galaxy s10e
0 Likes