Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Autoplay music in car

(Topic created on: 20-06-2023 08:41 AM)
2570 Views
Harry41
Apprentice
Options

Hi

Whenever I connect my S22 to the speakers in my car through bluetooth the music app on my phone starts playing music through the car speakers. It doesn't matter which music app I last used, it is always that one which plays. It is annoying because sometimes I just want to have the speakers connected to receive calls without listening to music. If I turn off the music player on the phone and then receive a phone call the player starts up again as soon as the call is over. 

Any suggestions how I can turn this off?

Thanks

0 Likes
13 REPLIES 13
Ruban7
First Poster
Options
Hi, You can try turning off the play back setting on your phone Samsung music player settings.
0 Likes
Harry41
Apprentice
Options

Thanks but I had already turned this off.  It made no difference.

0 Likes
Pugs1957
Samsung Members Star ★
Options
Try
On your Samsung Music app, tap on the more options icon and then select the “Settings”.

Turn off the “Allow external devices to start playback” switch.
0 Likes
Harry41
Apprentice
Options

Thanks but I already did that before posting my query.

AndrewL
Moderator
Moderator
Options

@Harry41: This is a strange one. Can you try heading to Settings > Advanced features > Bixby routines, and check to see if any routines are set up to open any media apps when you connect via Bluetooth? Furthermore, head to Settings > Sounds and vibration > Separate app sound, to see if this is set up to play media while connected to your car. It might also be worth checking your cars system settings to see if there are any automated options here. 

0 Likes
Harry41
Apprentice
Options

Hi Andrew

I spoke to BMW to see if it was something to do with the car settings. It turns out it is a standard feature, to turn on the music output whenever a bluetooth device is connected to the car. And it can't be turned off from the car. So thank you very much BMW!

Can you think of a way I might be able to switch it off from the phone? I have separate app sound, music share and allow external devices to start playback all switched off and I can't see that there are any Bixby routines set up.

Thanks

harry 

0 Likes
Pugs1957
Samsung Members Star ★
Options
Well that's strange, my M4 doesn't do that.
0 Likes
Harry41
Apprentice
Options

Agreed. That's what BMW told me though. Maybe its just Series 2.

0 Likes
AndrewL
Moderator
Moderator
Options

@Harry41: You could try heading to Settings > Connections > Bluetooth > On > Tap the cog to the right of your car system, and toggle off 'Audio' as a possible workaround. You also have the option of unpairing the system, then using Android Auto to re-establish the connection (Settings > Advanced features > Android Auto), as this could serve to override the automated features embedded in the BMW system. 

0 Likes