What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Original topic:

Error connecting to FTP or SMB server in "My Files" app

(Topic created on: 29-01-2023 07:10 PM)
Galaxy S20 Series

Dear all,

I have Android 13 on my Samsung Galaxy S20 Ultra.

When I try to connect to local FTP or SMB server via stock "My Files" app I get an error. I had the same issue on S10, so the problem is not solved over years.

The logfile on FTP server showing that I have entered IP address / port / username / password correctly:


2023-01-29 15:29:29,678 ftpd[1014072] localhost (Galaxy-S20.home[]): FTP session opened.
2023-01-29 15:29:29,683 ftpd[1014072]: TLS/TLS-C requested, starting TLS handshake
2023-01-29 15:29:29,703 ftpd[1014072]: TLSv1.3 connection accepted, using cipher TLS_AES_256_GCM_SHA384 (256 bits)
2023-01-29 15:29:29,730 ftpd[1014072] localhost (Galaxy-S20.home[]): USER xxx: Login successful.
2023-01-29 15:29:29,868 ftpd[1014073] localhost (Galaxy-S20.home[]): FTP session opened.
2023-01-29 15:29:29,875 ftpd[1014073] localhost (Galaxy-S20.home[]): FTP session closed.



The client connects OK, but does not do any transfers and simply closes the connection 🤕

Settings are: Encryption: Implicit, Transfer mode: Active. I have tried other combinations and all have failed in some way.

Error shown on the client Unknown error: vfs.provider.ftp/connect.error:


SMB fails as well. I have tried both user/password and anonymous / guest alternatives – both with an error. For anonymous connect I suspect it does not follow correctly the protocol (sends an empty user instead of marking it as anonymous 😱


[2023/01/29 19:34:14.819419,  5] ../../source3/auth/auth.c(auth_check_ntlm_password)
  auth_check_ntlm_password: sam_ignoredomain authentication for user [] FAILED with error NT_STATUS_NO_SUCH_USER, authoritative=0
[2023/01/29 19:34:14.819469,  2] ../../source3/auth/auth.c(auth_check_ntlm_password)
  check_ntlm_password:  Authentication for user [] -> [] FAILED with error NT_STATUS_NO_SUCH_USER, authoritative=0
[2023/01/29 19:34:14.819544,  2] ../../auth/auth_log.c(log_authentication_event_human_readable)                                         
  Auth: [SMB2,(null)] user []\[] at [Sun, 29 Jan 2023 19:34:14.819508 CET] with [NTLMv2] status [NT_STATUS_NO_SUCH_USER] workstation [] remo
te host [ipv4:] mapped to []\[]. local host [ipv4:] 


Displayed error:


Well, at least if the server replies with NT_STATUS_NO_SUCH_USER, the error message should be "Invalid user or password", not "Can't connect".

When I use user/password, the server logs confirm that the user is authenticated, but somehow the client messes up with shares 😵:


[2023/01/29 19:49:43.289817,  3] ../../auth/auth_log.c(log_authentication_event_human_readable)
  Auth: [SMB2,(null)] user [WORKGROUP]\[xxx] at [Sun, 29 Jan 2023 19:49:43.289802 CET] with [NTLMv2] status [NT_STATUS_OK] workstation []
 remote host [ipv4:] became [MYSERVER]\[xxx] [S-1-5-21-1901777980-1711874431-1648016913-3000]. local host [ipv4:192.16
[2023/01/29 19:49:43.474731,  3] ../../source3/smbd/service.c(make_connection_snum)
   (ipv4: connect to service IPC$ initially as user xxx (uid=1100, gid=114) (pid 1040925)
[2023/01/29 19:49:43.481981,  3] ../../source3/smbd/smb2_server.c(smbd_smb2_request_error_ex)
  smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[1] status[NT_STATUS_ACCESS_DENIED] || at ../../source3/smbd/smb2_create.c:334
[2023/01/29 19:49:43.487410,  3] ../../source3/smbd/service.c:1123(close_cnum)
   (ipv4: closed connection to service IPC$


I don't know why it tries to connect to share IPC$ – it has a special meaning and should be handled appropriately.

I didn't try SFTP because if it fails, I'll cry the whole evening 😭

My Files version
Network Storage Manager version