Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Wifi Disconnecting A34 / A54

(Topic created on: 14-09-2023 04:54 PM)
7855 Views
Chippy1965
Student
Options
Any tips to keep wifi connection active. Currently dropping signal often and have tried a few suggestions but as of yet none have solved the problem. I have resorted to leaving wifi off when at home as its so annoying.
8 REPLIES 8
Options
First thing is does this do it everywhere or just on the home WiFi? (And I'm sure you have already tried resetting router)
0 Likes
Chippy1965
Student
Options
Yes already done that but thanks for the suggestion
Badger42
Helping Hand
Options
You can try resetting the network settings if you haven't already. This is done via settings>general management>reset>reset network settings. Please note though this will reset WiFi, Bluetooth and Mobile settings.
JAMES4578
Samsung Members Star ★★
Options

@Chippy1965   A few ideas , you may not have tried some of them.  Go to Settings- Connections - Wi-Fi - Tap the cog symbol to the right of your router - Forget . This is the bottom right on the list. Toggle your Wi-Fi off and on again - Select your router from the list of available connections, and run through all the connection steps.

Thereafter go to Settings - Connections - Wi-Fi - Tap the cog next to your router on my device it is under view More but could be Advanced if that does not show. select the MAC Address Type and set this to Phone MAC. If the issue persists, I would suggest pressing the Volume Down and Power buttons together for around 10 seconds until the phone restarts, the reason being that this will refresh the software and address any issues that might be causing problems.  if still issues would be advisable to Reboot router,though you may well have tried this step before.

I do not work for Samsung or make Samsung Products but provide independent advice and valuable contributions.


Tractor777
Explorer
Options
Try turning off the "intelligent wifi" options (connect to mobile network, switch to better WiFi off). That has fixed the problem for me
Canisafricanus
First Poster
Options

@Tractor777 Thanks so much for sharing this tip; it worked for me as well. 

0 Likes
Stefanukas
Student
Options

Updated the A54 5G to latest, but the issue is not solved. For me the issue only appears while connected to Wifi5 or Wifi6. With enabled verbose logging it is switching between hasInternet:True and hasInternet:False.

While connected with Wifi 4 there is no issue. I could reproduce the same result with two different Access Points. (at home and in the office) just in case the AP is less the 2m away and with all other devices no issue.

 

In my opinion a case for Samsung customer support. 

kettle789
Journeyman
Options

I've enabled verbose logging on my handset, how do you read the logs?

0 Likes