Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

SD Card unmounting A53 5G

(Topic created on: 12-04-2023 02:20 PM)
396 Views
MathVDS
Journeyman
Options

I recently got myself a Samsung A53 5G.
But I am encountering the problem that the SD cards keeps losing "connection"
I used my Samsung Evo SD card that I got a few years back for my previous phone. (Galaxy A5) during a Samsung action.
The SD card works fine in my old phone. But in the A53 it keeps unmounting itself after a while.
(It is also not visible anymore in the storage settings).
The only option seems to be to restart the phone after which the SD card is available again.

The interval ratio seems to be rather random. (1-2days) and I can't seem to find a 'trigger'

I also did an unmount - mount cycle after a reboot and this runs normally but after a day, same problem.

I double checked that the SD card was fitted correctly (removed it and refitted it to be sure). But this didn't change a thing.

There seems to be more posts about this problem but there never seems to be a solution. From what I can see the Samsung SD card is just buggy af with a Samsung phone?

 
14 REPLIES 14
MathVDS
Journeyman
Options

Yeah, I think so too. Still somewhat strange, but it works now. So I guess I found my solution! Thanks

Nikosleov
Helping Hand
Options

Hi, Is it now working normally or is it disconnecting again?

0 Likes
MathVDS
Journeyman
Options

No further problems and disconects since changing the SD card. My old phone is still using the old sd card without a problem, so I guess it was some incompatibel issue. 

Members_a2ujvNA
First Poster
Options

I have exactly the same problem.  It is exasperating!

0 Likes
Oliverklozoff
First Poster
Options

I'm going through it myself. Wishing I'd bought a different phone kinda.  Hey SAMSUNG , since it's Your product how bout a free SD Card that works or a phone 🤷‍♂️ smh .  ( I've tried 2 New cards & 👎 no luck.

0 Likes