What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Original topic:

Mobile data connection problem

(Topic created on: 14-08-2021 04:30 AM)
Galaxy A Series
I can't seem to get a decent Internet connection 
Samsung Maker ★★
Galaxy A Series

Hi @Mikey69er 


This could be due to a number of factors.

  • Your masts are at issue or suffering from mast congestion. Perhaps check any available mast checkers for your network. That said they won't normally show mast congestion,  only known issues.
  • What data icon are you seeing at the top of your phone i.e 5G, 4G etc ? If your using a 5G connection then go into Settings and Connections and choose the 4G / 3G options if that change in connection settings is available to you to turn off 5G and see how you go.
  • Your sim card may be at fault. As a process of elimination try your sim card in another phone, and if possible another sim card in your phone to see what happens. Your network can replace your sim card via a Sim Swap.
  • In your phone look for the reset network settings to see if this helps.
  • Look to see you haven't turned On Data Saving.
  • Try clearing your cookies and data from your current Internet App.
  • Try using another Internet App from the Playstore.
  • Try Safe Mode. Put the phone in Safe Mode which disables your downloaded app's but let's your stock app's keep working. If the issues stop then this highlights a downloaded app as the possible issue. Come out of Safe Mode and start deleting your most recent downloaded app's one at a time until it stops. 
  • Try clearing your phone's System Cache Files. Clear your phone's System Cache Files by turning your phone Off and then from a set series of button presses go into the phone's System Files and clear the cache. No information is lost this way. You may need to insert your headphones or hook upto a computer with your data cable to get to this menu on the phone. 
  • Let a Samsung Experience Store or Samsung Service Centre take a look at your phone.

Daily Driver > Samsung Galaxy s²² Ultra 256Gb in Phantom Black.

The advice I offer is my own and does not represent Samsung’s position.
I'm here to help.