Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Incoming calls listed as private numbers

(Topic created on: 24-08-2021 08:56 PM)
morour
First Poster
Options
Galaxy A Series
All my incoming calls are listed as private numbers even if i have the contact saved on my phone. When i open my settings show caller information is on. Any ideas?
5 REPLIES 5
Mitzzz999
Hotshot
Options
Galaxy A Series
Does it still happen after a phone restart? Have you recently upgraded or changed networks?
0 Likes
BandOfBrothers
Superuser II
Superuser II
Options
Galaxy A Series

Hi @morour 

 

I'd start with contacting your Network's Customer Support Team and ask them about your Your Caller Line Identification Settings which may need to be activated. 

 

Also try.

  • Launch Phone App.
  • Tap on the 3 little dots in the top right hand corner.
  • Tap on Settings.
  • Tap on Other Call Settings.
  • Toggle on Show Caller Information.


Current Phone > Samsung Z Fold³ 5G.

0 Likes
Dollyyy
First Poster
Options
Galaxy A Series
Same problem happiness with my phone from yesterday
0 Likes
Wavytallman
Student
Options
Galaxy A Series
I'm currently having the same problem on my phone Samsung Galaxy s10e
0 Likes
morour
First Poster
Options
Galaxy A Series
Hi all, yes still happens after a restart and I've tried altering the settings. Will need to give them a call I think.
0 Likes