Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Incoming calls listed as private numbers

(Topic created on: 24-08-2021 08:56 PM)
59006 Views
morour
Student
Options
All my incoming calls are listed as private numbers even if i have the contact saved on my phone. When i open my settings show caller information is on. Any ideas?
10 REPLIES 10
Jo-Ann1
First Poster
Options

I had this problem on my S9 and figured the problem would go away when I bought an S24. It didn't and I have verified that all settings are correct.  Here's the weird thing, I gave my S9 to my husband and he put the sim card from his old phone in it (because I had taken the sim card for my new phone) and the caller ID now works fine on the S9. My provider tested my sim card and said it is working fine but I wonder.

0 Likes