Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Galaxy A40 Wifi Keeps Disconnecting After Update

(Topic created on: 24-11-2020 07:38 AM)
JDM3
Apprentice
Options
Galaxy A Series

My Galaxy A40 keeps disconecting from my wifi after an update on 26/05/20. My friend also has an A40 and updated his phone 1 week later and instantly had the same issue. The issue is only happening on my phone and not on my laptop, ruling out the posibility of my router being the issue.  screenshot of the errorscreenshot of the error

7 REPLIES 7
CarlH
Moderator
Moderator
Options
Galaxy A Series

Hi, @JDM3, hope all is well. Can you perform a Soft Reset please, and let me know if the issue persists? This doesn't delete anything from your phone, it fixes any minor issues that may be occurring. To do this, hold the 'Power' button and the 'Volume Down' button, both together for ten seconds and your phone will restart. 

Anonymous User
Not applicable
Options
Galaxy A Series

Go into settings, advanced functions or something like that (do not know the translation for it), then go into restore and use the restore network settings. You will have to re register all wireless devices, if it does not work you may consider a hard reset. Do my procedures after trying what @CarlH if it does not work!

Have a nice evening

0 Likes
JDM3
Apprentice
Options
Galaxy A Series

Hi @CarlH, I have peformed a soft reset as you suggested. I had done this about 2 weeks ago with no improvement, however I have just done it again and it seems to have fixed it so far, fingers crossed. I will see if it droppes out in the next few hours to be sure. 

Many Thanks, 
JDM3.

JDM3
Apprentice
Options
Galaxy A Series

Hi,  the soft reset has not worked and I am still having the same issue. I have also reset the network settings as suggested without any improvement.

0 Likes
TessM
Moderator
Moderator
Options
Galaxy A Series

Hi @JDM3 ,

 

Please check if you have the Wi-Fi set to Off or Never during sleeps period on your phone by going to Apps> settings> Wi-Fi> More> Keep Wi-Fi on during sleep.

 

If this is not the case, confirm that you don't have any power saving settings on your phone: Apps> Settings> Device maintenance> Battery. Can you try connecting to a different Wi-Fi network?

0 Likes
Perky
First Poster
Options
Galaxy A Series

Install Best Wifi Keeper app and turn off battery optimisation.

0 Likes
Mihai2Tone
Apprentice
Options
Galaxy A Series

Try to see if your wifi security has WPA3, if yes, switch it to WPA2. For me this fixed the constant disconnects while in lockscreen

0 Likes