Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

A40 keeps losing the wifi connection

(Topic created on: 16-06-2020 04:25 PM)
2493 Views
mike-1266
First Poster
Options

my A40 keeps losing the wifi connection in my house. My wife has the A5 and it never loses the wifi. this happens in any room in in the house including the room with the rooter. I have to disconect the phone from the rooter and reconect to get the signal back. when I have mobile data switched on the phone choses that rather than the wifi in the house. I also run my pc on the same network and I dont have any connection problems with that.

Please can any one give me some advice.

Thank you.

3 REPLIES 3
AndrewL
Moderator
Moderator
Options
@mike-1266: Sorry to hear that you're experiencing connectivity issues with your Galaxy A40. Please can you try going to Settings > Connections > Wi-Fi > Tap the 3 dots in the top right > Advanced > Switch To Mobile Data > Off > Turn On Wi-Fi Automatically > On. It may also be worth checking the 'Wi-Fi Control History' setting to see if the loss of connection is stemming from a third party app. If it is, go to Settings > Apps > Select the relevant app > Permissions, and disable any options relating to Wi-Fi control. Let me know how you get on.

0 Likes
Vltm
Apprentice
Options

I'm experiencing a similar issue with 5Ghz WiFi with ASUS RT-AC58U (RT-ACRH13) router. When A40 is placed in the area with a weak WiFi signal, an exclamation mark appears next to the WiFi icon (which is the correct behavior), but when you return to the area with a strong signal, the mark often does not go away and A40 does not reconnect to the Internet. The only solution is to turn WiFi off and then back on.

 

The strange thing is that the smartphone stays connected to the router (both A40 and router report the connection speed and signal level changes), but the connection is never restored. Changing channels and other advanced settings on the router does not help. I also noticed that the following message appears in the router's log when A40 connects to the 5Ghz network: [DEBUG]:skip vht opmode notification (change channel, number of spatial streams(NSS),or both). This message does not appear for other AC clients.

0 Likes
Perky
First Poster
Options

Bit late, but I fixed mine with the Best Wifi Keeper app and turned off battery optimisation.

0 Likes