Support

Open search

Amazon prime streams very dark

Highlighted
First Poster

TV ue50ru7020

 

Tried streaming some of Amazon uhd content on this tv and it's very dark, not looking like it's in hdr and occasionally flickers to a much clearer brighter picture (for maybe half to 1 second at a time) then goes back dark again.

You can still see the picture but it looks kind of like how a non HDR screen would show hdr content (grey looking whites).

 

Brand new TV, any idea what's wrong?

4 REPLIES 4
CarloL Moderator
Moderator

Hey @Garyc123! Are you still experiencing issues with this? If so, can you confirm if it happens only when streaming from Amazon or with every other channel/app?

Highlighted
First Poster

I am experiencing the same problem.  It is only with Amazon Prime Video, all my other services are fine.  It's only really noticable in darker scenes, they become astronomically dark.  My brightness settings and backlight settings are at the max, and still you can barely makeout some shapes.

Highlighted
Apprentice

Hey all,

 

When we got our QE75Q90R last year, I noticed this darkness issue too across various programs. It did really bug me as the TV was rated for a lot higher brightness than our old Samsung LCD.

 

On Amazon Prime it was very noticeable for the Goliath series (4k), as most of the shots were in a very sunny environment yet I could barely see what was going on as everything was so dark.

 

Also noticed this on Netflix when watching the new Bladerunner. It become very noticeable when running the credits where the TV was constantly adjusting the brightness for the scrolling text, making most of it illegible as it was all flickering in/out.

 

All of the above indicated the TV is trying to auto adjust brightness & dimming levels so after playing about I found changing the following settings made a huge improvement.

 

General > Intelligent Mode > Adaptive Brightness = Off

General > Eco > Eco Solution > Ambient Light Detection = Off

Picture > Expert Settings > Local Dimming = Low

Picture > Expert Settings > Brightness = 20 (this is a good minimum value for me)

 

Tried watching Goliath again with those new settings and the difference was incredible! The image was finally looking like what I expected for a big/new QLED!

 

Hope that helps guys.

Highlighted
First Poster

For anyone wondering, I spent hours talking to Samsung and Amazon support about this and none could resolve the matter. 

Samsung did say I could return the TV but in the end I couldn't be bothered, but more disappointing was that Amazon seemed to know more about the TV settings and adjustments than Samsung support did.

 

I did go to the engineer menu and disable the local dimming (what a stupid feature) and that did help out with Netflix which would darken the screen slightly when a dark scene was shown however this did nothing for Amazon. I'm basically stuck watching non hdr non uhd shows with Amazon as they unfortunately look much better than in 4k hdr- it's a pretty huge brightness difference.

 

So basically if you have this problem in this TV, suck it up because you can't fix it.

Top Liked Authors