What are you looking for?

Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Google Account failing to copy to new Galaxy Watch 4 Classic 4G -- unusable

(Topic created on: 06-09-2021 04:48 PM)

Hello, I just got a new Galaxy Watch 4 Classic 4G (purchased in the UK) but I am having trouble copying my Google account to it. My phone is a S20 Ultra 5G (purchased in Hong Kong, SM-G9880)

In the Galaxy Wearable app, After the *"Copying your accounts..."* screen I get a *"Couldn't copy your Google accounts"* error without any extra context or information.

I have tried resetting my watch, clearing app cache/data from the Galaxy Wearable app, and restarting my phone. I have not attempted a factory reset of my phone as I don't really want to do that unless strictly necessary.

I have contacted Samsung UK support and I've been told that one of the reasons this is not working might be the lack of the "Google Mobile Services" app from my phone, as it does not appear on the list of system apps:

> we highly recommend reaching our designated support team in Samsung Hong Kong so that they can also fully check if you can install/download Google Mobile Service (GMS) as this is one of the requirements for you to be able to fully use your mobile phone with your Galaxy Watch4 Classic

I could not find a way to get that installed on my phone, and I am not convinced this is the culprit anyway.

Things I've tried so far:

- Made sure my phone was fully updated
- Remove cache and data from Galaxy Wearable, Google, Google Play Services app
- Remove 2FA from Google Account
- Reset watch from the watch itself, in the recovery menu
- Restart my phone

Could someone help?


Managed to solve this by resetting the watch a few more times, maybe also disabling WiFi on the phone. It felt completely random, but it did copy the account.


I had the same issue.

The initial impression with this watch is quite negative, it must be said.

Anyhow, I kept trying to copy my google accounts over (I have several). I have a 4th account from my home country that has my youtube music account linked to it.
I kept trying to cope the account, but it always was stuck on "open your phone". On the phone side (S21 ultra), it went through the steps and then back to the home screen, without notification of success or not.

Opening youtube music again and selecting the accounts still showed only 2 accounts, not all 4.

I just forced the phone to turn off. I waited 20 seconds, turned it back on, entered the PIN, and the when I went back to youtube music, the accounts were all there and I could select them.


Hi guys,

Just wanna give another option to solve this issue.. Hopefully it'll will be fixed soon by Samsung

Meanwhile, until that time, try these following steps :

  • Reset your watch, clear cache & data galaxy wearable app on your phone, unpair bluetooth connection if it was previously connected, then
  • Install Wear OS by Google, connect your watch using this app for the first time. Just follow the instructions, and wait until it failed in the progress..
  • Stop the Wear OS (Google), Restart your watch, then connect using Galaxy Wearable (Samsung), and follow the instructions

I've tried 2 times using above steps and works fine.. Hopefully works for you too

Note : After succesfully installed, sometimes your watch disconnect from your phone, but you can connect again using the watch's application (playstore, customize watch apps, etc)

I really hope Samsung will fix this bug soon, so we dont have to get complicated to enjoy this premiun cool watch

First Poster

Hi there,


I just wanted to share what worked for me. I tried the other solutions on this thread and the other thread linked above but it didnt work for me.

In the end, all I had to do was sign out of my google account on my phone. It then sort skips the step on the watch set up. I signed back into my google account once the watch was set up and have had no issues since.


I think I Just discovered the fix, I reset my watch on accident and couldn't log back into Google and after a bunch of useless fixes I did this

  1. Go to settings on your phone
  2. Go to google
  3. Manage google account
  4. Go to security
  5. Scroll down to "your devices" and click
  6. Press 3 dots next to your watch and sign.         out

It logged me in right right away without even trying to login

First Poster

Yep, that worked for me. also, waiting/patience is a crucial part here also 


Disable phone security (biometrics, and pattern) temporarily

First Poster

Hi everyone. I had the same problem and I was able to fix it with one the methods that are posted here.

Try everything here:

1) reset both phone and watch

2) update related softwares

3) remove all google account except one

4) turn off your phone security (finger or pattern or code)

The last one worked for me.