Support

Open search

Gear S3 Zooming

Highlighted
New Member

My Gear S3 (D786) has been zooming in for no reason for the past few weeks. Sometimes it makes it hard to use the watch as it zooms almost every time I look at it. I reset it often but it doesn't help. I've changed the screen back to a Samsung face but it still does it.  My watch does not have a 'zoom' setting that I can find & this was confirmed at a Samsung store, so I can't just turn off the zoom function. The watch is about 16mths old. 

7 REPLIES 7
Highlighted
First Poster

@KimSung wrote:

My Gear S3 (D786) has been zooming in for no reason for the past few weeks. Sometimes it makes it hard to use the watch as it zooms almost every time I look at it. I reset it often but it doesn't help. I've changed the screen back to a Samsung face but it still does it.  My watch does not have a 'zoom' setting that I can find & this was confirmed at a Samsung store, so I can't just turn off the zoom function. The watch is about 16mths old. 


Me too!  It is so annoying and constant.  Rebooting helps for a minute, but it’s soon doing it again. Please help before I throw this piece of ***** in the trash can!

Highlighted
New Member

 If you tap 5 times on the screen, its gone.

Highlighted

THANKS THATS AWESOME!

Highlighted

Hi you need to go to settings, accessibility, visibility enhancement and the turm off zoom.

Highlighted

Thanks! It worked 😊

Highlighted

Thank you for your help!

Highlighted
New Member

To correct the zooming issue, you must do it on your phone through galaxy wearable app, under accessability, visibility enhancements, zoom off

Top Liked Authors