Support

Open search

Gear s3 disconnects when I open camera app

First Poster

I have a Huawei Mate 10, I recently updated my gear S3 to the latest firmware. 

I was getting disconnected often, tried doing as everyone sugges3by clearing cache on Bluetooth etc. Made no difference. 

30mins ago I opened my camera app and instantly I get a notification saying my watch was disconnected. So I reconnected and tried it again. Same thing. 

I cleared the cache on the camera app, made no difference. 

 

Any advice? 

16 REPLIES 16
Sorry to hear you feel you're being missed out in this, @Maclac. If you're still experiencing the issue, you can also reach out to our Technical support team to discuss this. They can be contacted on the phone number I sent to @4my earlier. We apologise for the delay, and not getting to you sooner.

If anyone finds a solution to this issue, can I ask that they please post it here for the rest of us? Thanks!

New Member

Same problem Huawei Nova 3i, opening camera app dissconnects S3.  Does NOT reconnect by itself. Most frustrating.  Think I'll get rid of the watch.  Obviously a very narrow support angle from Samsung.  Very dissapointing.

New Member

I fixed it by doing reboot. Hold power until it says rebooting

Observer

You need the give your plugin the permission for the camera.

 

settings>apps>watch active plugin>allowances>allow to use camera

it's not true, i have every permission allowed on my phone (permissions for following apss: watch plugin, galaxy wereable, samsung accesory services) and still my watch get disconnected when i open the camera app.  

Observer

same thing here with Honor 8X EMUI 10 and Nokia 4.2 Android 10.

The watch disconnects when starting an App (not only camera) and do not reconnect automatically.

Top Liked Authors