What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Gear S3 Classic watch stuck in reboot loop

(Topic created on: 09-02-2018 10:49 AM)

Hi there,


Purchased a Gear S3 Classic watch in October and, for some reason, woke up this morning and it was stuck at the "Samsung Gear S3 Classic" login screen and not starting up.


I've read numerous posts from people having the same issue and I've also tried the various fixes (pressing the power button until "rebooting" shows, pressing power button multiple times, selecting "recovery" option etc) but NOTHING is working. All I have now is a very expensive watch stuck on a login screen.


Has anyone figured out a fix for this issue yet or have any suggestions about how to get this problem resolved?


Sold all my Apple gear (iPhone, Apple Watch, Macbook Air, iPad Pro) back in October to move everything across to Samsung (S8 Phone, Galaxy Book 2 in 1, Gear S3 Classic watch). I'm hoping I haven't made a mistake. Come on Samsung prove to me I've made the right choice.

Samsung Members Star ★★

If you have tried all the know reset options which i believe are....


Turn the Gear S3 off.

Press and hold the Power key until REBOOTING displays at the bottom of the screen.

Press the Power key repeatedly until the Select REBOOT MODE screen displays.

Press the Power key to highlight ' Recovery'.

Press and hold the Home key to select.

Keep holding the Power key until the Gear S3 begins rebooting.


and thats failed then it sounds like a software or hardware failure which needs looking at by an engineer at a Samsung Experience Store or Samsung Service Centre location. 



Daily Driver > Samsung Galaxy s²⁴ Ultra 512Gb ~ Titanium Black.

The advice I offer is my own and does not represent Samsung’s position.
I'm here to help. " This is the way. "


I have the same issue. This is unacceptable from Samsung


Same here...something Samsung should fix urgently or re-imburse for purchase

First Poster
I am having same issue, my gear s3 frontier stuck in rebooting loop. I have still warranty on my watch and sent for repair, to my surprise Samsung shipped me back without fixing. I called and got surprised answer that motherboard has water damage, which I dont belive because my watch been never use in water, I belive this is software or hardware issue, and also i see no water under watch glass.
Other bad part Samsung has no repair center in FL whe yiu can go in person.

Last year I bought 2 note 8 and 1 watch and 2 galaxy S7 phones, I moved from apple and I must admit I start regretting moving to Sumsung.

Apple has much better service and more helpful to do everything to keep you as a customer.
Samsung show me that I made a right decision to move fr ol m apple to Samsung, so I am regretting and I will call tomorrow again to see if they give my option to fix my watch.
First Poster

I am very disappointed on samsung, a week ago my gear s3 frontier started to do the same thing, rebooting itself, I thought it was something with the buttum stuck or something but now is dead, it does not respond anymore. it only have six months it is unacceptable.


Apparently this issue happens very often. Let’s be honest with each other this might to do with water. Therefore , Samsung advertise this watch as water resistant. I even saw an ad with someone putting the watch under water, not deep, but it was under water. I’m pretty sure that none of us, had swim with the watch. I think the watch looses water resistance properties within time. We’ve been mislead by Samsung. That is why they should honor their guarantee. Regardless of the time. This watch is not water resistant period. I bought myself a LG sport watch... to punish Samsung. I loved the gear S3 Frontier. But this misleading information from Samsung led us to a trap. Don’t advertise the watch as warer resistant. Not true.




I'm seriously disappointed in the customer service I received from Samsung. Very, very poor and completely regret giving them a chance to use their products.


Basically I got in touch with their support team, with regards to this matter, and received a snooty email back basically washing their hands of the issue.


Apparently as I had bought my watch through eBay the serial number was for a different country and the UK support team wouldn't be able to help. I was told to get in touch with the support team in the country I bought it - explained I bought it in UK but still wouldn't help. Pathetic in every sense of the word. To get it fixed I'm apparently to travel to Germany, France or whatever country it's from to get them to repair it.


Wow thanks Samsung. Now I'm left with a very expensive watch which I can't use. Pretty much going to have to bin it - and that REALLY annoys me. Especially when it would take Samsung UK a few minutes to reload software.


I've now passed my Samsung Galaxy Book to my wife, bought a Huawei Watch 2 smart watch (runs Google's Wear OS) and I'll be looking at a Google Pixel 3 phone to replace my S8 when it's launched in October.


I'd heard Samsung support wasn't very good, now I have first hand experience if how really bad it is. 


Poor show Samsung.


I'm completely with you guys here!.

I got this as a gift from a (now sadly deceased uncle), when it was stuck on the boot screen I tried everything. Let the battery run out, Kept the power button on till I got the scroll screen. Still nothing. It's been nowhere near water. 

I contacted the generic help desk which was in the US. They told me to take it to my own country Samsung which was fortunately a few miles up the road in New Zealand. They said since it turns out it was bought in China. I'd have to send it to Samsung China. It gets better. Their website is in...yup chinese. So I wrote saying I don't speak chinese and got a response in - Yup you guessed it . Chinese!!!. They gave an address to send it. Get this. Because it has a battery - it's $100 to send!!! I am severely disappointed in the terrible "help" from Samsung. I think this is the end of a long term relationship.  

Anyone had any help with this common problem that a big company like Samsung should sort out? Samsung! If you want to do something useful , how about taking all these watches with the same problem and fixing them!!!! Grrrrr

First Poster

I just had my Gear S3 Frontier stuck in boot loop and I tried the master reset method without success. I was able to fix my watch and this is how I did it:

1. Put the watch on the charging dock

2. While in the dock hold the home button until the reboot screen shows up

3. Press the home button a few times until the menu comes up and press the home button until you highlight power off

4. hold the home button to select the power off option and let the watch power off until you see the charging screen

5. From here try to turn on the watch as normal, if this doesn't work try the master reset method while the watch is on the charging dock.


I hope this helps!