Open search

Galaxy watch heart rate monitor and alto not working


As per the title, my watch was working fine but just today the heart rate monitor has gone haywire. The laser for reading the heart rate is flashing continuously after trying to take a reading and the watch says it couldn't measure my hr even though the display looks like it's taking readings.

   I've tried reseting the watch, same thing and turning off and on again doesn't work. Seen others on the boards having similar problems, should I return the watch? Still no word on my duo charger being delivered either.


Alt barometer is also stopped working saying I'm at 44000 m when I'm on the sofa at home. Seems pretty screwed up.


Same symptoms here with heart rate monitor.


I turned auto measurement off, rebooted the watch, then did a manual HR measurement. Appears to be working (shows an animation), then fails with "Can't measure heart rate, try again."


Of course, trying again doesn't help. After the first try the green sensor light flashes continuously, even if I take the watch off. Probably using up battery faster as well.


I factory reset the watch and restored the settings. Same result.


No response from Samsung, I assume they're waiting until we all can no longer return the watches.


yeah I just returned my watch last week and got a refund. If its stopped working already its a bad sign.


Seeing the same - looks like its sensing heart rate - see the trace etc. But then 'couldn't measure heart rate, please try again' messgae and it doesn't work. Have tried factory reset, clearing ram, storage, disabling eliptical and rowing machine as per samsung advice elsewhere, restarted, changed from always on to frequently / never and none of it makes any difference

First Poster

Hi from Spain!


I have the same problem, I bought my Samsung Galaxy Watch (SM-R800) in september 7th and it worked fine until 3 days ago, when I noticed yesterday that the HR info was not updated in the last two days. I tryed manual measurement and apparently works but after a while I get the error message.


I'm considering all my options before taking a decission.




It's been over 2 weeks after running an update that my gear fitpro2 stopped working.

Steps, stairs, sleep record, HR monitor, etc stopped working. All it does is measure the BMR calories and it still pushes notifications from phone.

It does not detect any workout despite workout detection being switched.

I had reported to Samsung was told to do the following

In order for you to solve this issue, please go to Settings > Apps > Galaxy Wearable > Storage > Clear cache, Clear data.

Also, please try to turn the Gear device off and turn it back on; if this does not solve the issue, please perform a Light Reset (on the Gear: Settings > About Gear > Reset Gear > Light Reset). If the issue persists, please perform a Factory Reset, from the same menu."


I have done all above including a full factory reset, losing all my historical data and yes the problem does persist and I have recontacted.


Samsung what other options do I have?


Is there going to be an update?


It is terribly inconvenient to hold my phone during workouts.

Please let me know.



I got the same problem! How did you solve this issue?


I returned my first watch because of the heart monitor problem. The replacement I got has been fine for many months (including heart rate measurement, sleep monitoring and so on). So I believe this is a hardware issue, not a software bug. My advice is stop trying to reset, etc. - see if you can get Samsung (or whoever you bought it from) to give you a new device.


I didn't return mine while waiting for some acknowledgement from samsung, any response what so ever but nothing. Absolutely useless customer support.

However, after a software update the hrm sorted itsself out and has been fine ever since. So am inclined to believe it was a software issue...

Be helpful if samsung bothered to respond to customer complaints in some form

Top Liked Authors