Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Caller ID not showing in watch when contact number has the country indicatives?

(Topic created on: 07-01-2024 12:11 PM)
1617 Views
Afladimir
First Poster
Options

This week I found out that if you have contacts with a country id, when they call you it wont show their id but their number. Is there any way to fix this?
The only one I found so far is to have both numbers in the contact one with the country indicatives and the other without, so the watch can recognise it. But it will take time to go through all the contacts and duplicate the number without the indicatives.
For context I have a GW6 classic with the lastest available version

5 REPLIES 5
Bk787
First Poster
Options

I too have found this problem... When I save the number without the country code then the watch recognizes it, but not with the country code

MaciekPL
Apprentice
Options

same here - phone recognizes caller-id without problems, watch doesn't.

Watch 6 + S23U

NO caller-id name if calling number is shown without country ID
number in the "contacts" saved with country ID and another one without.

Caller-ID is working when calling number is shown with the country prefix (+48 in my location)

0 Likes
Members_EE7CwJu
Student
Options

Exactly same issue for me, Samsung Watch 6 Classic BT + mobile Samsung S23. Samsung Support claims it will not work on BT version but only on LTE. That's not true, since everything was working just fine for 2-3 months, now it stopped. 

MaciekPL
Apprentice
Options

I have the LTE version (but no eSIM card installed) and Caller-ID is not working. Seems some silly error of recognizing numbers with/without country code

0 Likes
Roberto2808
Apprentice
Options

Dear Samsung Community and Support,

I have deliberately decided to store all my contacts with their corresponding country codes a long time ago, and never did I face any issue with my Samsung phones not recognizing the contact name properly.

However, it's been just recently (within the last 24 hours) that my phone has started to show the calls for numbers that don't have a Country Code on Recents tab without a contact name (despite having those numbers already stored as contacts). This behavior appears to affect even the calls from previous days, despite the fact that those calls didn't have any incident on the days when I received them, but now they do have such incident and their contact info is not shown. This behavior for the calls from previous days is shown on Samsung Phone App, but also replicates on Google Phone App.

It's worth mentioning that I can't recall any recent update on my phone throughout the last week.

Another thing to point out is that, for example, some of the calls from a contact are received with the Country Code recognized and included, while some of the calls from this same contact are not. I find this helpful for the analysis, since the issue reported seems to affect the incoming calls from numbers received without Country Codes only.

And here one last thing to point out is that, when I allow from the Secure Folder settings to show the information of stored contacts outside the Secure Folder and one of my contacts calls me without the Country Code recognized, then that Contact name is actually recognized this time, with a Secure Folder icon appearing next to the name. It seems kind of weird that those are then actually recognized, but as Secure Folder contacts, and they're not properly recognized when I hide the information from Secure Folder contacts outside the Secure Folder.

Here I share more information of my device:

Device Model: SM-N975U1

Country: Peru

Android Version 12 - OneUI Version 4.1

Please, Samsung Team and Developers, kindly check it.

Kind regards,

Roberto Ampuero

0 Likes