Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

The Frame 2022 lagging and Slow OS

(Topic created on: 30-11-2022 08:14 AM)
gnav144
First Poster
Options
TV

Hello,

I got my Frame 2022 75" 2 days ago. While setting up i noticed the OS was kind of slow and when i was pressing buttons on the remote nothing would happen and suddenly all the buttons i pressed in the past (like 10 seconds ago) would work at once. I didn't think much of it and thought it could be the wifi issue or something. I gave it the ethernet connection, resetted the tv, re-paired the remote and the same issue is still happening, everything is so slow or when sometimes i press buttons nothing happens and screen just freezes. Remote battery is at 87%. 

I have also tried removing the apps that i am never going to use and theres nothing else connected to the tv either just an ethernet connection. My connection speed is close 900mbps. 

 

Anyone having the same issue or had the same issue? I have contacted support thorough tv. They will call me tomorrow. just wanted to bring this up here as well. Tv software 1310

6 REPLIES 6
Members_KdC6HWR
First Poster
Options
TV

I'm having the same issue, it sucks, such an expensive TV to be that slow...

Ahaddad
First Poster
Options
TV

Same issue! Any luck? My TV’s firmware is up to date: 1420.9

0 Likes
Original6ix
First Poster
Options
TV

Hi, same thing happening to me here in Canada. Super laggy and will lag up to at least a minute before kicking back in

Ahaddad
First Poster
Options
TV

I read on reddit that it could be from faulty remotes, replacing it might do the job. Going to give it a test!

0 Likes
Phoenixfire425
First Poster
Options
TV

Same issue here..   And I noticed since the last update that the picture mode motion detection barely works now too.....  The new 2022 interface is awful.  We have the 20221 and 2022 models and the 2021 UI\UX is by far easier to use and faster...  Common samsunng... You can do better then this. 

0 Likes
meckermeck
First Poster
Options
TV

Hi all, (The frame 43'', 2022 model)

I wanted to express my own disdain. I have the same behavior. I virtually tried every thing. (Reset, different combination of setup paths.)

I can add, that the issue seems to worsen when trying to use any of the HDMI connections. Those never work, also, but I could still think this might be a problem on the connected device's side (Laptop). Funky enough, it workt _once_, but not at beginning, just randomly.

Another curiosity: If I switch to Art Frame Mode (by pressing Off for a short time or by selecting a motive in the art-store), the TV just restarts. Meh. I don't know if that is related. I didn't subscribe to the store, but I would expect there to be at least one free motive and/or that the tv didn't just restart.

Did any of you guys found a solution for the problem?

0 Likes