Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Subtitles Not Showing Up on All Chanels - Samsung Q80A 55" TV

(Topic created on: 22-12-2021 07:26 PM)
xameleon
First Poster
Options
TV

Hello,

Few days ago, my family bought Samsung Q80A (our old TV is Samsung too) and after running it we noticed there are no subtitles in our local language for channels like Animal Planet or  National Geographic. I'm a bit technical so I set the preferred subtitles in  the options to be "Bulgarian" for all avaialable options. But subtitles are still not showing up.

What can be the issue?

0 Likes
3 REPLIES 3
xSteveuk
Maestro
Options
TV
Hi
Try below

Make sure that the subtitle function has been enabled. Go to tools > Setting > Subtitle Setting. Select "On" to enable subtitle
0 Likes
xameleon
First Poster
Options
TV

Yes, I did that. And set all the options for language of subtitles to be Bulgarian

0 Likes
xSteveuk
Maestro
Options
TV
OK
Try below

Turn on the TV and press Menu on the Samsung remote control. Select “Accessibility” in the General menu. Select “Subtitle Settings” and select “Subtitles” to turn on subtitles. Select “Subtitle Mode” to change the subtitle language
0 Likes