Open search

Samsung tv stopped reading usb drives

First Poster

I have a Samsung UE55NU7023 i was playing back content just fine today and after i ejected my usb stick and insterted after 10 minutes without doing anything that would cause trouble my tv stopped loading anything from the usb port. It kep loading the usb forever when i tried to access it. I tried multiple usb sticks and it did the same thing. But when i had a single folder with a video in one usb drive the tv prompted me as always to play the video without opening the files and it played the video just fine, but when i tried to access the files after that i couldn't. What is going on? The port clearly works, what should i do? 


Accepted Solutions
First Poster

The solution that worked for me was to go into settings into External Devices Manager (not sure how it is in English, my menu is in Polish) and remove all my phones, tablets etc.


Than I switched off the TV, disconnected the USB drive and turned on my TV. It still works. I hope it helps. 


Merry Xmas and Happy New Year :winking-face:

View solution in original post

206 REPLIES 206

Hi @Chrislsk.


Could you tell us the current software version of your TV? Go to Home > Setting > Support > About This TV.

Hi I’m having a similar problem.


its been fine recently until about 2-3hrs ago.  Will not read any usb flash drive.  Samsung upstairs does though.


tv in question is UE46F8000ST running software version 1135, latest version according to the software update function in settings>support.


USB port powers flash drives with voltage as flash drives light up.

Hello dear

My samasung ju7000 has recently stopped loading USB contents , before was ok but now seems to have some issues. 

I have done anythin, my TV already had the latest firmware (1530) . I have done what I could think of , factory reset, hub reset, changing region , changing language, I changed anything on TV , even tried to degrade the firmware but was not able to. 


Can't understand what could be the cause

Something when I turned the tv on I can see the contents of USB and even play videos but when I try to browse folders it hangs and the next time I try to see the contents It keeps loading ...

I was planning to play with the hidden options of tv but I am bit scared that could brick the tv ...

Any help could be life savings!!!

Is there a fix for this? My UN75JU6500FXZA is doing the same thing.

Exactly the same thing happened to me: When I got to the USB input page, I can navigate around one or two files until the whole thing freezes--and then Smart TV launches itself. Does anyone have any advice? I made sure I had the latest software installed (which I do), so this seems to be something that needs a fix on Samsung's side. 


I've had the same issue.  Watched a show from inserted usb, left it in as usual and next night won't load files. Recognises the usb is in.  Tried both ports, today tried them on other Samsung tv in other room. Reset smart hub and nothing.  Usb is fine as using it now on other devices.  very annoyed.  Tvs under 2 years old.  Seems like happening to a few.  

I have the same issue, I have been with online chat for over two hours, still not resolved, the agent offered no insight as to why this has happened other than instructions to try an alternative USB.  If it is of any help, if you have an Android phone you can download Smartview.  I can't promise it will resolve your issue as I can't try myself as I have an iphone.  I am sooo annoyed - I will not be purchasing  another Samusung TV or and Android phone

Laura, I knew there wouldn't be an answer,  seen too many complain about it with no resolution. 

This has really soured my opinion on Samsung, how does a function of the tv just stop working for no reason.  

Hi Lee Have you tried to download Smart View from Google Play - it is absolutely dire, there are probably hundreds of comments with users saying it doesn't work.  I wondered why the agent I was talking to online was almost avoiding the topic.   I know that I used to be able to connect a PC to my TV because I remember trying to sort out Windows 10 so I could boot from a USB.  Currently, a different PC is attached to my TV and can only be recognised as part of the network,  but NO CONTENT FOUND, if I take out the ethernet connection from the PC it doesn't show at all and that is through HDMI.  TV Boxes (ie sky and YouView are fine) USB connects with media files on it is recognised but NO CONTENT FOUND.  I have been messing with this all day, it seems smart view is the answer but that is POS according to one comment! on Google Play apps  I really didn't want to go down the App/Network route as the potential for errors is off the scale; now confirmed

Top Liked Authors