Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

QN90B problems with HDMI connections

(Topic created on: 02-12-2022 07:44 AM)
2748 Views
Pete2345
Journeyman
Options
I've just received my 65" QN90B TV and I love it however I'm having problems with the HDMI connected devices. 

Connected I have;
Xbox One
Sony Bluray Disc player
Sky Q

On connecting the devices they were all recognised by my TV and worked great but I've had a daily occurence where I will power the TV on, select the 
device and it says it cannot find the source. This has been with Sky and the BD player but not the xbox so far. This is both after choosing to power on the connected device with the TV and by powering on the device using its own control. 

The connected device will be powered on but my TV will just show that the source cannot be detected and trouble shooting doesn't help.

If I disconnect 1 side of the cable and reinsert it, it 
works again. If I unplug and reset the Sky or BD without touching the HDMI, it works again. 

I've changed the HDMI cables for other cables but still have the same problem. The cables I use have been in use for over a year with no problems and when the devices are connected sucessfully there are no problems. All cables are HDMI 2.0 and from different manufacturers.

I'm on the current firmware version available 

Any ideas?
































































































































































0 Likes
10 REPLIES 10
AndrewL
Moderator
Moderator
Options

@Pete2345: If the problem has persisted after using an alternate HDMI cable for the affected external devices, then please try powering off the TV, unplug it at the wall for 30 seconds, then plug it back in. Now, power on the external devices, then power on the TV and head to Home > Source. Let me know if this helps. 

0 Likes
Pete2345
Journeyman
Options
Hi, that didn't help. I went through all the menu's and saw that "Input Signal Plus" was turned on. I've turned this off for all HDMI's and I've not had the same problem since.

Is this a side effect of using Input Signal Plus when the device isn't a Game console?

I'll let you know if I have any further problems
0 Likes
Pete2345
Journeyman
Options
It's definitely the Input Signal Plus thats causing the problem.
I had no problems when it was disabled.
I accidentally turned the option back on for the Sky HDMI whilst playing with my xbox (I thought the HDMI went from 1 on top to 4 bottom but it's the other way around) and the problem came back.

I thought that was the end of it and sorted but it seems as though my TV is enabling Input Signal Plus for the HDMI sky is connected to on its own but randomly and not all the time. Any ideas why?
MrIain22
Student
Options

I have the same problem with my new QN90B 

every morning have to unplug/plug in sky Q box 🤦🏻‍♂️ , not impressed.

does turning off input signal plus for the sky box take away from picture quality? If so that disappointing 

0 Likes
Pete2345
Journeyman
Options
No it doesn't. From what I've seen it's actually only designed for gaming so turning it off doesn't matter.
0 Likes
MrIain22
Student
Options

Good to know, I’ll turn it off 🤞 

thanks mate 

0 Likes
Calitoo
First Poster
Options

I purchased my 65" QN90B TV along with a new TIVO 4K Edge in October 2022 and not long after started having problems getting "No Signal" when I turn on the TV set to the TIVO's HDMI.  I would have to unplug the TIVO's power cord or HDMI cable and plug it in.  It would detect it and I would then see the picture.  The rest of the day when the tv was turned on it would be ok.  Issue started happening every morning.  I used a new 4k HDMI cable, switched to a different HDMI port and had the problem.  I made calls to TIVO support and went through troubleshooting to the point I got them to send me another brand new replacement.  Issue started happening with it.  I then called Samsung support, went through their troubleshooting even doing a factory reset.  They then referred it for a technician to come out.  They made some system changes (not sure what).  Worked for a few days and issue started occurring again.  I called Samsung again and awaiting them to refer it to a technician again.  I read this thread and disabled the Input Signal Plus for this HDMI port, but still had the problem.   Again, unplugging the HDMI cable or powering off and then on the input source device then it starts working.

3/1/2023  update

Shortly after this post, I stopped having the problem.  Unfortunately, I don’t know what changed.

0 Likes
chillAtGVC
First Poster
Options

I am having the same problem with a Formuler Z11 box.  It does not affect my Apple TV or (soon to go) cable box.    Input Signal Plus was on (just playing around) and I turned it off and rebooted the TV.  I still have the same problem.  I really don't want to have to unplug my Z11 box every day!

0 Likes