Open search

Q7FN HDMI resolution indicator not updating




When using HDMI inputs (ex. PC), when you press the OK button, on the top right part of the screen, it shows the resolution that you are currently using.


I have noticed that when I change resolutions, ex. going from 1080p 120Hz to 4k 60Hz, or whatever small change you might do, the indication does not change. So, I might be running my PC on 4k 60Hz and the indication still shows 1080p 60 Hz from the previous setting that I had when I first turned on the TV. And the only way to see the current resolution is to actually turn off the TV and turn it back on again.


I confirm that the same problem existed with the Q7 2017 model because I actually had one a while ago.


Is there a workaround or a fix? I am using latest firmware 1202.



Just Browsing

I have two devices (Nvidia Shield and PS4) connected directly into the tv and am having this problem. My shield is set to stay on when the tv turns off and when I turn the tv back on it will sometimes display the correct resolution but most of the time it wont.


Something that has been working for me is to have the devices on and then press and hold the power button on the TV remote while it is turned on. Ill keep holding onto the power button on the remote until the tv restarts and shows the Samsung QLED logo and then let go.




Well, this is still a problem.  I've just updated to the latest firmware and while there's a new behaviour to note, it doesn't fix the issue.


So, after updating to 1270 I tested the resolution indicator and lo-and-behold it was updating correctly without me having to bring up the info panel during changes.  I already knew to taper my excitement from previous experience though so I switched everything off, waited a minute and switched everything back on.  No prizes for guessing what happens next.  That's right, it's back to behaving the same old way again.


I've tried everything I can think of to replicate the state the TV ends up after a firmware update.  I tried running all manner of apps, input switching, unplugging the ConnectBox from the mains and reconnecting.  Nothing I do now will get the indicator working again though.


In summary, there are only 2 scenarios where this problem goes away - after Samsung remote support mess around/reset the ConnectBox and directly after a firmware update.  In both cases, the fix only lasts until the TV is power cycled and then it's the same old problem.


Pretty sick of this now, nobody at Samsung gives a toss, or at least none of them know how to escelate this is anyone who can do actually do anything about it.  Pro tip for techincal/firmware departments at TV manuactures - read your user forums once in a while, you might see some actual feedback from people using the rubbish you're shoveling out. 


It's almost funny, I have a £1500-£2000 TV here that can't keep track of simple information like current resolution and HDR status! smh, I give up.


I've only just seen your reply DoctorAcula, thanks.  I tested and found the same thing, a soft reboot actually cures the problem, it just has to be done every time you use the TV.


I updated to 1270 today and the problem remains the same.


I had the exact same problem with my Q9FN. I resolved it with Autorun Smart Hub "On" in Smart Features. I saw that on other forum.


Thanks for the suggestion although I've just tried it and it doens't help on my Q7FN.  SmartHub is auto loading but the indicator still doesn't work.  The only solution that works for me is still holding down the power button on the TV remote to make it reboot.


Hi guys,


It's been a long time since I first opened this thread and I don't believe Samsung will address this issue anytime soon (probably never).


So I have marked @Beeswax 's workaround as a "solution". It's not a solution but it works 100% every time.




This issue + CEC breaking all the time and having to completely pull the power cord out of the TV to fix it put me off on buying another Samsung TV in the future. The panel is fine but the software and support is a disaster.


Hi @caboomgr I actually find that @DoctorAcula 's solution is a bit better - simply turn the TV on as usual then once it's on, hold down the power button.  Keep holding after it's turned off and it will come back on again  -a  'soft reboot' if you like.  I find that if I do this, the status indicators all work as expected without having to mess about trying to perfectly time [info] presses on the remote.


Still a bit rubbish that we have to do this when stndard features like this should just work and a double shame that @Samsung don't even respond here.




Yes this is one of the first things I was testing out when trying to find a workaround myself. It might work correctly for the first 5 minutes or so but after a while it stops working again. Most people won't notice this bug, we only notice it because we change resolutions/refresh rates/hdr on-off quite often during the day.


The best workaround (for me at least) is to press the OK button once just before you change the resolution.




With a new firmware 1282.3 same thing.

Top Liked Authors