Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Netflix sound not working on UE50NU7400 with digital output

(Topic created on: 28-12-2018 06:59 PM)
Alan2018
Journeyman
Options
TV

I've had a Samsung Smart TV linked via an optical out cable to a Marantz CR610 hifi system for 4 years and everything worked OK, including Netflix.

 

The old TV gave up the ghost, so in September I bought a new Samsung UE50NU7400 4K TV, connecting it exactly the same way as the old TV.

 

The sound from the TV to the Marantz system works fine, just as before, whether the content comes direct from the TV or from the Sky box which.  The one probem is Netflix.  Netflix works fine through the TV speakers, but if I switch on the Marantz system the Netflix app carries on playing the picture, but no sound comes through the optical out cable to the Marantz system - we just get silence.

 

It appears to be a weird aspect of the Netflix app, but since it worked on the old Samsung TV it seems odd that it's stopped working on the new one.

 

Anyone have any ideas?  Thanks.

1 Solution


Accepted Solutions
Solution
Alan2018
Journeyman
Options
TV

I contacted Samsung support and they sent me this set of instructions.  Don't know which part worked, but by the end I was getting sound out through my Marantz system again when using the apps.  Initially I had to manually switch audio from TV to the Marantz system in the app, whereas I didn't just using the Sky box.  But then I turned the TV off and on again, and suddenly it switched automtaically again, just like my old TV.  So here's what they sent.

 

1. Plug in then power the TV and Marantz system on.

 

2. Set the function mode on the Marantz system depending on the optical connection that it has with the TV.

 

3. Press the 'Home' button on the TV remote, select 'Source', and choose 'TV'.

 

4. Press the 'Home' button on the TV remote, select 'Settings', and choose 'Sound'. Select 'Sound Output' then set it to the 'Audio Out/Optical' or the option pertaining to the Marantz system.

 

5. Press the 'Home' button on the TV remote, select 'Settings', and choose 'General'. Select 'Network', choose 'Open Network Settings', and establish the network connection. Choose 'Network Status' then cancel the network authentication, select 'IP Settings', and choose 'IP Setting' then set it to 'Get Automatically'. Select 'DNS Setting' then set it to 'Enter Manually', enter '8.8.8.8', and reconnect the TV to the network.

 

6. Press the 'Home' button on the TV remote, select 'Settings', choose 'Support', and select 'About This TV' then get the complete software version code.

 

7. Perform the Smart Hub reset.

 

        7.1. Press the 'Home' button on the TV remote, select 'Settings', and choose 'Support'. Select 'Self Diagnosis', choose 'Reset Smart Hub', and enter your 4-digit PIN (Default PIN: 0000). Finish the Smart Hub setup.

 

8. Press the 'Home' button on the TV remote, select 'Apps', and search for the Netflix and Amazon apps. Download each app then check the 'Settings' option to confirm the audio format and sound settings.

 

9. Press the 'Home' button on the TV remote, select 'Settings', and choose 'Sound'. Select 'Expert Settings', choose 'Digital Output Audio Format', and set it to the appropriate format. If you use a receiver that does not support Dolby Digital Plus, you will hear no sound if you select Dolby Digital+.

 

10. Play a content to check the sound quality.

View solution in context

135 REPLIES 135
Zakaria_E
Pathfinder
Options
TV

Hello,

 

You can do this manipulation Please? and tell me if it works.

 

Home > Sound Settings > Expert Settings > Digital Audio Output Format > PCM

Alan2018
Journeyman
Options
TV

Hi Hamzaoui

 

Thanks, but I checked this already - it is set to PCM.

0 Likes
Alan2018
Journeyman
Options
TV
Quick update. Just found that the same problem happens with Amazon Prime.
0 Likes
JanJan1
First Poster
Options
TV

Hello,

I have the same issue. Same television but with a Yamaha receiver from january 2017. It worked fine on my Sony Smart 4K tv but not on samsung. The helpdesk of Samsung could not help me. Youtube works via the audio receiver 

 

Grtz

AndyR954
First Poster
Options
TV
I just bought the UE55NU7100K and having the same sound issue with Netflix,l. Everything else is fine but this. I got one thing to work by stopping then continuing but it doesn't work all the time. Annoying. Still looking into it,will post if i find anything.
Solution
Alan2018
Journeyman
Options
TV

I contacted Samsung support and they sent me this set of instructions.  Don't know which part worked, but by the end I was getting sound out through my Marantz system again when using the apps.  Initially I had to manually switch audio from TV to the Marantz system in the app, whereas I didn't just using the Sky box.  But then I turned the TV off and on again, and suddenly it switched automtaically again, just like my old TV.  So here's what they sent.

 

1. Plug in then power the TV and Marantz system on.

 

2. Set the function mode on the Marantz system depending on the optical connection that it has with the TV.

 

3. Press the 'Home' button on the TV remote, select 'Source', and choose 'TV'.

 

4. Press the 'Home' button on the TV remote, select 'Settings', and choose 'Sound'. Select 'Sound Output' then set it to the 'Audio Out/Optical' or the option pertaining to the Marantz system.

 

5. Press the 'Home' button on the TV remote, select 'Settings', and choose 'General'. Select 'Network', choose 'Open Network Settings', and establish the network connection. Choose 'Network Status' then cancel the network authentication, select 'IP Settings', and choose 'IP Setting' then set it to 'Get Automatically'. Select 'DNS Setting' then set it to 'Enter Manually', enter '8.8.8.8', and reconnect the TV to the network.

 

6. Press the 'Home' button on the TV remote, select 'Settings', choose 'Support', and select 'About This TV' then get the complete software version code.

 

7. Perform the Smart Hub reset.

 

        7.1. Press the 'Home' button on the TV remote, select 'Settings', and choose 'Support'. Select 'Self Diagnosis', choose 'Reset Smart Hub', and enter your 4-digit PIN (Default PIN: 0000). Finish the Smart Hub setup.

 

8. Press the 'Home' button on the TV remote, select 'Apps', and search for the Netflix and Amazon apps. Download each app then check the 'Settings' option to confirm the audio format and sound settings.

 

9. Press the 'Home' button on the TV remote, select 'Settings', and choose 'Sound'. Select 'Expert Settings', choose 'Digital Output Audio Format', and set it to the appropriate format. If you use a receiver that does not support Dolby Digital Plus, you will hear no sound if you select Dolby Digital+.

 

10. Play a content to check the sound quality.

Sirgord
First Poster
Options
TV

In sound settings, expert settings, turn off dolby digital.

 

0 Likes
edelml
First Poster
Options
TV

I had the same problem, I did the following steps.
I start Netflix and played something and with the video playing I pressed the Setting button in the remote control and then Sound > Expert Settings > Digital Audio Output Format, and here I changed Dolby Digital to PCM and the sound started.

punt1
First Poster
Options
TV

This solution worked for me too.  Simple and clear.  My menu settings were slightly different but the key was to go into streaming mode and go to your sound settings to change Dolby to PCM.  I had already made the change in broadcast TV mode.  I thought the sound settings would be global, but they are different. Thanks for the easy fix!