Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Strange physical keyboard behaviour

(Topic created on: 08-11-2020 01:42 PM)
12717 Views
sgzmd
First Poster
Options
Hey folks,

I have two questions about Samsung Tab s7+ physical keyboard:

1. How can I use multiple layouts with it, e.g. English/French? I have multiple layouts set up for Physical Keyboard, pressing Shift-Space (or any other combination - Ctrl-Space, Alt-Shift) shows on-screen toast that layout has changed, and it changes the layout of on-screen keyboard, but doesn't change physical keyboard state.
2. Whenever I start typing with physical keyboard connected, on-screen keyboard shows. Selecting keyboard symbol in the tray and unchecking "On-screen keyboard" does basically nothing - keyboard is still shown.

image

Here's how it looks. Pressing keyboard up/down button on the physical keyboard doesn't seem to have any effect. I am normally using gBoard but it works exactly the same (for both questions) with Samsung's.

Thanks in advance for your answers!
16 REPLIES 16
bmariam89
Apprentice
Options
I somehow had managed to remove that button and was trying to get it back. Thanks for the help.
Its easier to choose the on screen keyboard for when I am using the keyboard at night but turn it off for the times I find it easier on a physical keyboard.
0 Likes
bmariam89
Apprentice
Options
I just use the physical keyboard without changing the language for when I am speaking Portuguese but the characters are almost the same than English. Just have to use c instead of ç, and forego éóàáãô but its for family so they understand. There may be a way to change it but I am not sure I would remember the shifts, and control needed for that. I have the samsung keyboard, which came with the samsung tab s8.
You can try following the screenshots and let me know if they help you.Screenshot_20230103_185353_Settings.jpgScreenshot_20230103_185545_Samsung Keyboard.pngScreenshot_20230103_185626_Samsung Keyboard.jpg
0 Likes
dsent
First Poster
Options

This is so ridiculous. The end of 2023 is approaching, and this years-old problem doesn't seem to be neither fixed, nor even worked on. Samsung just ignores their customers' needs.

0 Likes
Orlean
First Poster
Options

Very frustrating. However I did something and can not replicate on second device. I have now two samsung keyboards listed in the physical keyboard. And I can now switch languages (works on two different physical keyboards). If I can do it for Gboard ....

edit: Actually, on my other samsung (tab s20) when I selected now samsung keyboard it appear in the physical keyboard as two separate keyboards, each with different language. Again ... wish the Gboard did the same :smiling-face:

1000019406.jpg

0 Likes
dsent
First Poster
Options

Well, it's quite unlikely that Gboard will do that, as every other vendor except Samsung works with the stock Android system and doesn't create separate keyboards for every language. Samsung does its own thing that is not supported by anyone else. Basically, it's up to Samsung to stop that and change their system to work like Gboard (and every other Android keyboard).

0 Likes
Alex Nachev
First Poster
Options

Heyyyy Samsung.... we pay the premium ... let us chooose our keyboard to be gboard!!!! Allow it in  DEX tooo. Dont be an apple.

0 Likes
dsent
First Poster
Options

They've changed the behavior in One UI 6. Now the layout switches between all enabled languages of all enabled keyboards. But you can't disable Samsung Keyboard, so the best case scenario with 3rd party keyboards is that you're stuck with one extra layout (you have to have Samsung Keyboard enabled and at least one language there).

This is better than it was previously, but still not nice.

0 Likes