Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Strange physical keyboard behaviour

(Topic created on: 08-11-2020 01:42 PM)
sgzmd
First Poster
Options
Tablets
Hey folks,

I have two questions about Samsung Tab s7+ physical keyboard:

1. How can I use multiple layouts with it, e.g. English/French? I have multiple layouts set up for Physical Keyboard, pressing Shift-Space (or any other combination - Ctrl-Space, Alt-Shift) shows on-screen toast that layout has changed, and it changes the layout of on-screen keyboard, but doesn't change physical keyboard state.
2. Whenever I start typing with physical keyboard connected, on-screen keyboard shows. Selecting keyboard symbol in the tray and unchecking "On-screen keyboard" does basically nothing - keyboard is still shown.

image

Here's how it looks. Pressing keyboard up/down button on the physical keyboard doesn't seem to have any effect. I am normally using gBoard but it works exactly the same (for both questions) with Samsung's.

Thanks in advance for your answers!
11 REPLIES 11
Maroš
Voyager
Options
Tablets
turn on DEX mode, then go to settings, there is an option turn it on or off
0 Likes
degreeze
First Poster
Options
Tablets

I have same problem (the first one) with multiple language layouts for physical keyboards on S7 tablet. And it's Samsung OneUI problem that needs to be fixed ASAP.

 

The thing is that language selection menu in "Settings > General management > Language and input > Physical keyboards" does not support multi select and allows you to choose only one language.  Same behavior for Samsung Keyboard and Gboard.

I tried same steps with same bluetooth keyboard on different device (on latest Android One) and it's working flawlessly. And that is only because then i go to "Language and input > Physical keyboards" and click on any keyboard - i see list of languages with multi select options.
Problem on S7Problem on S7No problems on Android One deviceNo problems on Android One device

nrsyn
First Poster
Options
Tablets

I face the same problem too. I already go to the setting as per mentioned and already unchecked 'on-screen'. but the on-screen keyboard still appear

0 Likes
prorokrak
First Poster
Options
Tablets

No fix even after a year? I am facing the same problem with Tab S5e with OneUI 3.1. I can setup the keyboard correctly on my other device Oneplus3 with Custom ROM Android 11 but not on the Samsung device. I am stuck with English and there is no way to change it. Or, more precisely, I have changed in the settings language to Slovak (tried both with Samsung keyboard and Swiftkey) but the settings do not work. No Slovak characters can be entered, just English layout.

0 Likes
Jonail
First Poster
Options
Tablets

its not a device-specific issue. in my case everything works fine if use samsung keyboard. GBoard has only one physical language in the settings and at the real. But, oddly, pressing shift + spacebar changes onscreen GBoard language. 

0 Likes
Ignacio83
First Poster
Options
Tablets

There's a workaround. 

1. Add keyboard button on navigation bar: Settings > General management > Keyboard list and default

The button appears at the bottom right corner of the screen when you type

2. When you need to use a physical keyboard, use this button to switch to Samsung keyboard. Takes 2 seconds.

Now you're able to change the language of the physical keyboard.

3. When you do not need physical keyboard, switch back to your preferred virtual keyboard (e.g. Gboard)

Not ideal, but better than nothing

0 Likes
THISISOTTER
First Poster
Options
Tablets

2022, still having this problem. (tab S7)

0 Likes
THISISOTTER
First Poster
Options
Tablets

It is a Samsung tablet OS issue, probably INTENTIONALLY due to manipulate user to use a Samsung Keyboard input method over the third party one. If it is not, they should have fixed it already due to it is a default way of Android OS that allow user to be able to select a multiple Languages with one Physical keyboard.

And Of course, this will happen to other third party keyboard too, not just Gboard (tested on Tab S7 at 18th March 2022 on)

Oleksandr Zalishchuk
First Poster
Options
Tablets

Your workaround is good, thank you.

I am still waiting for Samsung to fix this issue.

0 Likes