Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

How can I change physical keyboard shortcut to switch language?

(Topic created on: 08-03-2023 02:01 AM)
najevi
Apprentice
Options

If you use more than one language input method then you will know that Shift + Space cycles through the user specified languages. While typing this brief post I have accidentally switched from english to japanese twice! 

I wish to change that keyboard shortcut to something that I am less likely to accidentally press. e.g. Command + Space or Control + Alt + Command, etc.

Has anybody found a way to do this successfully?

(I am using a bluetooth physical keyboard.)

Samsung Galaxy Tab A (2016) with S Pen         SM-P585Y

Android version 8.1.0     Samsung Experience version 9.5

0 Likes
4 REPLIES 4
najevi
Apprentice
Options

Just to be clear, these are the various keyboard shortcuts and I think that these are specific to Samsung Keyboard.

Where are these keyboard shortcuts specified/configured?Where are these keyboard shortcuts specified/configured?

 

It seems that whether I disable or enable Samsung Keyboard (e.g. to use, say, Gboard) as soon as I connect to a bluetooth keyboard the Samsung Keyboard (and this set of keyboard shortcuts) insinuates itself into my Physical Keyboard settings.

 

 

 

 

0 Likes
AckeeOnWalkee
First Poster
Options

I know it's been like half a year, but did you ever figure out a solution to this? I did find where to change it under the Physical Keyboard settings, but regardless of what I change it to it Shift + Space will change the language (and whatever I choose in the settings will not)

0 Likes
najevi
Apprentice
Options

No. I never found a satisfactory solution. 

An app called "Keymapper GUI keyboard" looked promising but not what I was looking for. You may find it useful.

 

0 Likes
dsent
First Poster
Options

The only workaround is to switch to Samsung Keyboard when using physical keyboard, then switch back to a normal keyboard, when not using it. It seems that this extremely annoying bug is intentional.

0 Likes