Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Galaxy S21 Ultra takes forever to Load apps and internet!!!

(Topic created on: 22-02-2022 07:00 PM)
3741 Views
Bzak1pgh
First Poster
Options

Samsung needs to work on a fix to address this issue!!! It's happening to a LOT of these phones!! It's takes a lifetime to load apps and Google searches or internet sites!!! It's been on going for me since a couple of updates they sent out a while ago!! Usually take 10 to 15 minutes just to load to what I need!! It happens sporadically but especially when I need in the time of need!!! Annoying!!!!!!

0 Likes
5 REPLIES 5
Knightshift76
Voyager
Options
Literally download Good Guardians from the Galaxy Store and run the app Optimiser.
GoanGeek
Samsung Members Star ★
Options
I prefer the repair apps in wipe cache menu.
Don't ask my why as I have no clue.
"WI-FI went down for five minutes, so I had to talk to my family.
They seem like nice people"
JAMES4578
Samsung Members Star ★★
Options

Hi @Bzak1pgh  Have you cleared the cache partition?  

  1. Turn off the device.
  2. Connect To Computer or plug in USB-C Headphones  , Press and hold the Volume Up key and then press and hold the Power key 
  3. When the Android logo displays, release all three keys.
  4. An 'Installing system update' message will show for 30 - 60 seconds before the Android system recovery menu options appear.
  5. Press the Volume down key several times to highlight wipe cache partition.
  6. Press Power key to select.
  7. Press the Volume down key to highlight yes, them and press the Power key to select.
  8. When the wipe cache partition is complete, Reboot system now is highlighted.

Press the Power key to restart the device

 

Afterwards run the Galaxy App Booster available via Good Guardians as @Knightshift76  suggested. 

I do not work for Samsung or make Samsung Products but provide independent advice and valuable contributions.


Ginga_p
Troubleshooter
Options
What does repair apps do in the menu? or does it do what it says on the tin
G G
0 Likes
PandaJunkie
First Poster
Options

Okay so I had/have hopefully not have anymore this issue.. I think I might have fixed it out of sheer luck and playing with settings. I am not sure what it was exactly because I did a few things but I will list them all and I hope it helps.

I went into settings/connections/wifi and hit the gear on the connected wifi. I turned Mac address type to phone Mac. I also turned it to treat as unmeterered connection.

Then I went back to wifi settings/advanced and turned off switch to mobile data and wifi power saving mode. 

I hope it helps. My phone hasn't had any issues since. I even had did the optimization for apps in good guardians but that did nothing for me. 

Update: Spoke too soon

0 Likes