Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

smartswitch

(Topic created on: 23-06-2022 05:24 PM)
rogern2
Apprentice
Options
Mobile Apps & Services

Hi

I have been using smartswitch for years but now it will not Sync the calender fom Microsoft Outlook 2010 to my Galaxy S10e

The message is: 0x8002801d library not registered.

I have cleared the cashe & data on the smartswitch app on my phone.

I have just had a new desktop with Windows 11, could that be anything to do with it.

All help will be appreciated

Regards

0 Likes
7 REPLIES 7
Pugs1957
Samsung Maker ★
Options
Mobile Apps & Services
That is a Windows error, try repairing your Outlook installation.
RETIRED
0 Likes
Midge123
Navigator
Options
Mobile Apps & Services
Hi try uninstalling outlook and reinstalling it again might help
0 Likes
rogern2
Apprentice
Options
Mobile Apps & Services

Hi

Thanks for that, I did a repair but the message is the same.

rogern2
Apprentice
Options
Mobile Apps & Services

If I unistall & reinstall wont I lose all my emails & calender appointments though?

0 Likes
Pugs1957
Samsung Maker ★
Options
Mobile Apps & Services
Hi, sorry about that, it would probably be an idea to post on Microsoft as I suspect there may be a missing or unregistered dll.
RETIRED
0 Likes
rogern2
Apprentice
Options
Mobile Apps & Services

Smartswitch - Outlook 2010 Syncing problem fixed!

Hi all

Re "Library not registered" in Outlook 2010 & Smartswitch syncing.

The repair detailed below worked for me yesterday (1st July 2022)

So you bought a new computer and it came with Outlook 2013 installed as a trial and you used it for a bit and hated it and decided to revert to Outlook 2010 and all of a sudden your COM addins went mad and started throwing horrible looking errors that said things like:

Unable to cast COM object of type ‘Microsoft.Office.Interop.Outlook.ApplicationClass’ to interface type ‘Microsoft.Office.Interop.Outlook._Application’. This operation failed because the QueryInterface call on the COM component for the interface with IID ‘{00063001-0000-0000-C000-000000000046}’ failed due to the following error: Library not registered. (Exception from HRESULT: 0x8002801D (TYPE_E_LIBNOTREGISTERED)).

The problem is caused by some Registry entries which need to be edited. Here’s how to fix it.

1) Open Regedit and find HKEY_CLASSES_ROOTInterface{00063001-0000-0000-C000-000000000046}TypeLib
2) Find a ‘(Default)’ entry with the value ‘{00062FFF-0000-0000-C000-000000000046}’ and make sure the “Version” Data is set to 9.3 for Outlook 2007, 9.4 for Outlook 2010 or 9.5 for Outlook 2013.
3) Now navigate to HKEY_CLASSES_ROOTTypeLib{00062FFF-0000-0000-C000-000000000046} and delete the version entry 9.3, 9.4 or 9.5 corresponding to the versions of Outlook you are NOT using.

The istructions in bold above fixed it for me.  Problem solved!

Make a Registry Backup before this fix and reboot after making changes to the Registry.

Hope it works for you.

 

0 Likes
medicmomsi
First Poster
Options

Is anyone else dissatisfied with the recent redesign of the Smartswitch appearance?

I just find its a very clumsy, poorly designed layout, with too many functions not readily visible or spread out. It took 3 uses before I realized there was a horizontal scroll of files you can  check off that are not visible at first glance.

In PREFERENCES, The old version was easy to just uncheck Music. I found it wasteful to keep using backup space for a new copy of my music folder as it rarely changed. 

Specifying  the location of the backup folders was not easily found  because there is a second nearly invisible second scroll bar on the right side. It should be high contrast, not light gray.

Last  I cant select to backup my Secure folder. There is some message about verifying your identity that flashes on the screen and disappears in 1 second. After 3 attempts I could read it but there is no instruction on how to verify your ID, or where. This should be a very clear selection option as Im sure many of us want that backed up.

0 Likes