What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Original topic:

Samsung Rcs Not working. Chat settings says register failed

(Topic created on: 18-09-2021 01:02 AM)
Mobile Apps & Services

Long story short. I had to take my sim out of my galaxy 20 note ultra to a dinosaur Samsung phone to contact my husband as my phone was not fully charged. Once house power was back on I charged my phone and inserted my sim back in. The chat in samsung message however had changed from the RCS (I think that's what it is called) that it was before. When I go to open chat messages it tells me what it does and I click on ok. Then it does this glitch thing and comes up registration failed. I've tried everything to clearing storage to all the possible YouTube quick fixes and nothing works. I'm still using mms. I can use google messages with RCS fine but I hate the layout of it and just want my original set up back. Anyone else have similar problem or have a solution. 

First Poster
Mobile Apps & Services

I feel your pain! I tried Google messages but I don’t like it. It compresses your pictures til it’s blurry. I had RCS up until I tried Google messages. Samsung messages won’t let me use RCS anymore without registration failing. I even got a new phone and it still fails. I tried chatting online with Samsung. No one has a fix or they’re rude. I’ve tried everything! Hope you get it working.