Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Samsng Gallery - OneDrive Sync - Not Working

(Topic created on: 06-07-2021 10:16 AM)
9999 Views
DrJake
Explorer
Options

So recently, when we we're 'forced' to move away from the Samsung Cloud, it came up with a notification to 'move to OneDrive'.

I've always been synchronising/backing-up my photo's to OneDrive anyway, but I clicked it, with no idea what happens. It went through the motion of linking my Samsung and Microsoft accounts.

Thereafter, it stopped backing up to OneDrive, and did it directly through Samsung Gallery - didn't even know that was possible. The option to back-up from my Microsoft account within OneDrive has vanished, too.

So, this Galaxy S9, the phone in question, it stops syncing (stops backing up to OneDrive) and I have no idea how to fix it.

- I've clicked the 'Sync' button a million and one times, no luck, tried turning sync on and off. Someone, somewhere mentioned about going to accounts, then choosing OneDrive, then turning on 'Media Storage', that doesn't fix it, either.

- I've restarted multiple times (May seem obvious, but just writing everything tried)

- I've tried 'clearing data' and re-installing OneDrive (even though it doesn't matter of you have the OneDrive app installed)

- I've ensured Samsung Gallery and other related apps have the latest updates

- I've made sure the phone has the latest firmware updates.

I'm worried, that my pictures are not being backed-up - (which they aren't, as they do not show in OneDrive).

Any advice on how to fix this?

Thank you.

12 REPLIES 12
DrJake
Explorer
Options

So, this worked for a some time, and now back to how it was again 🤷🏻‍♂️

Can't seem to find a solution in sight!

0 Likes
Debaschmidt
First Poster
Options

Hello all, I also had the same problem but recently I had another solution.

Instead of Gallery Sync use Media Storage sync .

go to settings -》 Accounts and Back up -》Manage Accounts-》 select one drive -》 click on Sync Account  -》Turn On Media Storage sync

Kreston
Apprentice
Options

After a while searching forums and dealing with this issue I have found MY fix and will post it everywhere to help other. 

 

Samsung Website

  • Got to samsung dot com  
  • Login to you your account
  • Go to services and unlink microsoft, if it's there, if not move on

Microsoft website

  • Go to microsoft dot com
  • Sign into your account
  • Go to security
  • Then advanced security
  • Then apps and services
  • If samsung is in there, unlink it, if not move on

Samsung Phone

  • Go to the Google Play store and uninstall OneDrive. It will not remove it, it will only remove the updates.
  • Then finally, go to the samsung Gallery app
  • In the app setting, go to Sync with OneDrive and enter your info as normal. 
  • You will know it has worked if it shows you a visual picture of the samsung and microsoft app icons linked together asking for permissions and confirmation. Proceed to sign in and you should be good. 

 

Hopefully this helps others out. It appears to be a samsung to microsoft account linking issue. They do not appear to be checking in the accounts prior to connecting. Bad programming really. 

 

Best of luck to all!