Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Calling Connectivity Issue

(Topic created on: 18-03-2024 01:05 AM)
1435 Views
ali_127
Student
Options

Hi everyone,

I have an issue with my s24 ultra phone related to Wi-Fi calling. At home, I rely on Wi-Fi calling big time as the signal to telecom tower(s) is weak. When I bought the new phone, I was not able to run Wi-Fi calling at my home network. I was able to run the same in other Wi-Fi networks, but not at home. I am using Deco XE75 (mesh network) at home. I did the below troubleshooting without success:

- Turn on/off Wi-Fi calling from settings.

- Reset my phone network settings.

- Disable "Mesh Technology" in my Deco network settings.

It is work highlighting that when I use my old phone on the same network, it works fine!.

I am not sure if S24 ultra uses some specific port(s) for Wi-Fi calling that needs to be configured in the router - Port Forwarding.

Appreciate your help as this is making troubles for me. Thank you.

Galaxy S24 Ultra

0 Likes
5 REPLIES 5
Reylob
Samsung Members Star ★
Options

Hi @ali_127 

I am able to use the feature without issue. I have a Galaxy S24 Ultra. I have my internal network "separate" from my ISP.

My ISP router is in modem-only function and my routers does all the internal settings.

I thought that maybe your phone is struggling between Wi-Fi connection and Network connection.

You could try changing Wi-Fi to be the prefer method.

Open the phone app, tap the 3 vertical dots menu, tap Settings

Settings -> Wi-Fi Calling -> Calling preferences - Wi-Fi preferred

Alternatively, check that Wi-Fi calling is activated, set the phone on Flight mode, activate Wi-Fi and try to make a call. Does it work?

I do not think that port forwarding is your issue. I will look at settings on the router, check if there is something stopping internal traffic. I do not have experience with Deco XE75, so I do not know where those settings might be on you router.

Is there an ISP router between your Deco XE75 and the outside world? If that is the case, check that your ISP router is not in router mode. Having both on router mode, might cause the ISP router to drop some internal traffic.

ali_127
Student
Options

Thank you for your feedback Reylob,

Very interesting points. Indeed, I have a router connected to ISP and using Deco XE75 as an access point to connect my phone. What you mentioned about using the first router as a modem-only function is interesting. Is this something your trigger in the router settings?

Following on the Wi-Fi Calling issue, I did some troubleshooting since that time I posted my question and realized a strange fact. I managed to enable Wi-Fi Calling in my phone by simply changing my phone local IP address! from what I saw, the IP address does not need to be specific. It might work with some IP address but then disconnect after sometime so I change my IP address again and it works.

Now, I have another issue as I am not able to enable Wi-Fi Calling for the two Sim cards I have in my phone. When it works, it works for one Sim card only, sometime Sim_1 card, sometimes Sim_2. I tried to switch the Wi-Fi Calling on/off for the Sim card that is not working but it did not help.

Appreciate your thought in this, thanks.

0 Likes
Reylob
Samsung Members Star ★
Options

I do not know which ISP you are using and they might no support it, but I think most of them will have this feature.

If you login into the ISP router configuration page, you should be able to configure this function.

Usually the the IP is something like 192.168.XXX.1 where XXX depends on the ISP configuration. e.g 192.168.100.1

Most ISP routers have the login details included on the router, they usually have a label saying the default password and username.

Once you are login as an admin, then you should be able to find a settings where you could use it in modem mode or router mode.

Once you do that, login into your Deco and enable router mode, and check that on the LAN settings the DHCP server is enable.

Th IP of the phone is a red herring, it should not affect that functionality. The phone should pick an available IP from the pool and work no matter what. You are having some network misconfiguration somewhere along your settings.

You SIM Wi-Fi calling might related to the preferred method, if your preferred method is mobile network, then it might trying which ever sim you set as the default Mobile data SIM.

You could try setting it to Wi-Fi preferred and then open a phone app ring a contact using the desire SIM.

Or like before check that Wi-Fi calling is activated, set the phone on Flight mode, activate Wi-Fi, and then open the phone app select a contact and then dial using the appropriate SIM.

I am assuming that when you tap on a contact you get the option of calling the contact with one SIM or the other.

ali_127
Student
Options

Thanks for your reply Reylob.

I have my phone Wi-Fi set as "Wi-Fi preferred" for Wi-Fi Calling all along. It is indeed strange. I am making things work temporary by adjusting IP. As my network is being used by many people, I hope to get a chance later on to adjust the router as a modem-only function.

0 Likes
gazwales
Apprentice
Options
I had this issue but never had it on my previous phone I think samsung have faulty phones
0 Likes