Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Sleep mode is turned on at the wrong time.

(Topic created on: 07-04-2024 12:34 AM)
419 Views
neonfour
Pathfinder
Options
Current time 00.30 Sunday.

Set Sleep mode to turn on on Sunday only at 23.00 to 06.00 next day. All other options can be set or ignored.

When saved, Sleep mode is turned on automatically. It should not be turned on as the last 23.00 passed was Saturday, and 23.00 on Sunday will not happen for another 22h30 mins.

0 Likes
9 REPLIES 9
AndrewL
Moderator
Moderator
Options

@neonfour: Are you able to expand on your query, as this will help to accurately troubleshoot the issue? For instance, what time is Sleep mode scheduled to activate, and what time is it actually switching on? In the meantime, please head to Settings > Modes and Routines > Sleep > Turn on automatically, and double check the sleep schedule and any conditions you've added. 

0 Likes
neonfour
Pathfinder
Options
Sure. Remove all sleep modes.

Follow the steps above tor recreate sleep mode.

Ive just created one now. Sleep mode to be active from from 2210 on Sunday to 1000 the nezt day.

It should not be active yet. It should not come for another 12ish hours and turn off tomorrow at 10am not todayScreenshot_20240407_094907_Clock_1000009415_1712479748.pngScreenshot_20240407_094915_Modes and Routines_1000009416_1712479755.png
0 Likes
AndrewL
Moderator
Moderator
Options

@neonfour: As it is not quite 10:00am yet, Sleep Mode has activated in keeping with your schedule. Wait until it reaches 10:00am, and check to see if the mode de-activates.

0 Likes
neonfour
Pathfinder
Options
It turned off at 10.00 but see the date. Sunday. I'd expect that to be start on Sunday not end on Sunday. Especially when it says

Sleep schedule: 22:10 - 10:00 the next day, Every Sunday

The next day. The day after Sunday is Monday. I'm not on Monnday yet. We're not on the next day for it to turn off.
0 Likes
AndrewL
Moderator
Moderator
Options

@neonfour: It must be the case that Sleep mode needs to be set up with the waking time set for the specified day. In your case, this would run from Saturday night at 22:10 to 10:00am on Sunday morning. If you keep this in mind, and treat the waking time the same as, say, an alarm, then the feature should perform as expected. 

0 Likes
neonfour
Pathfinder
Options
Which is wrong then because it doesn't clarify which it applies to
0 Likes
AndrewL
Moderator
Moderator
Options

@neonfour: I do appreciate the confusion that this may have caused you. If you select 'Monday', does this allow for the Sleep schedule to be accurately represented, so it starts on Sunday and ends on Monday? 

0 Likes
neonfour
Pathfinder
Options
No. To be honest, I'd consider this bad design, a bug that I've reported and discussed and won't get looked at by Samsung and so I've stopped using it. Sane with lots of Samsung software
0 Likes
neonfour
Pathfinder
Options
@AndrewL

Testing this again. Selecting Thursday 10pm to come on shows active on Wednesdays and goes OFF at 6am Thursday
0 Likes