Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Premium Text Services on S22 Really frustrated with this

(Topic created on: 05-04-2023 06:12 PM)
1295 Views
Pilot152
Student
Options

I have done everything that I can find on the forums but nothing is working. I have checked with my service provider and the premium texts are authorised. I have an unlimited spend so no cap on the contract.  I have changed my settings so I have enabled the premium texts on handset. I have made sure that I am using the right messages app. The message initially didn't send but now is sending but with no confirmation returned. Any other ideas as I am at a complete loss. Service provider saying speak to Samsung and then Samsung saying speak to service provider. Incredibly frustrating as only upgraded three weeks ago and this problem persists. I have also put sim back in old phone and the message will send and I get a confirmation of entry etc back

 Just not on the S22. What else can I try???

7 REPLIES 7
Tourbillon De La Vie
Samsung Members Star ★
Options

So, what happens? 

0 Likes
Pilot152
Student
Options
Text sends but no confirmation of entry received. I also have to use this service for banking transactions and still text will send but no code received back
0 Likes
Tourbillon De La Vie
Samsung Members Star ★
Options

That's a nasty bug which I sadly didn't manage to help resolve a relative of mine (using Motorola so it is not Samsung specific) . I went to the bank, to the service provider, changed sims. Nothing. No confirmation on the phone but apparently the code is sent on the back end but it is just not coming on phone 

msyeang
First Poster
Options

Hi - Am wondering whether you have found a solution for this ? I'm stuck in the same situation, where i cannot grant my messaging app the permission to send premium messages.

0 Likes
AndrewL
Moderator
Moderator
Options

@msyeang: Please can you confirm if you have tried heading swiping up from your Home screen and heading to Settings > Apps > Tap the 3 dots in the top right > Special access > Use premium text message services > Select your preferred messaging app? 

0 Likes
msyeang
First Poster
Options
  • Hello! I have gone there, and no messaging apps appear. Also my telco confirms that I have access to premium sms. Thank you. 

Screenshot_20230405_075800_Settings.jpg

0 Likes
Asteradi
First Poster
Options

I too am facing the same issue. No apps shows up use premium text message service screen. Already checked with my provider, this service is enabled for my no.

0 Likes