Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Galaxy S22 Ultra won't connect to pc via USB

(Topic created on: 20-06-2022 11:45 PM)
79738 Views
Rocatah
Explorer
Options

Hi all.. I'm hoping someone can help me out.

I've had my S22 U for just 1 day and I can't figure out why my PC doesn't see it.

Using a USB-C to USB-AI connevt the phone to the pc, I swipe down the noti. area, and there is the setting labled 'Cable Charging'. When I click on this It is supposed to open the 'what do you want to do' Transfer photoes, files etc.. But it instead goes to the battery page.

I have enabled USB debugging and Transferring files is selected..

Have tried a couple of different cables and a couple of different USB ports.

I've installed DEX (not sure what it is really), and that doesnt recognise when my phone is connected.

I can pair them via Bluetooth, but can only xfer files only, not folders. So music will take far too much time.

Win 11

Hope someone can enlighten me..

Thanks so much

Tracy

66 REPLIES 66
Tourbillon De La Vie
Samsung Members Star ★
Options

If you connect any other USB device does it get detected? restart the pc if not already and also use original cable you got with the phone 

0 Likes
Rocatah
Explorer
Options

Hi..

I also have a Huawei that connects no problem. I've restarted both the pc and the phone numerous times  over the last 24 hrs. 

Re the cable. My computer doesnt have a USB-C port, just USB-A, so I'm having to use the cable from my Huawei. The S22U did connect once this afternoon, and I was able to xfer some files then, but it hasn't connected since..

It's a bit, nay a lot, confusing. 

Thanks

T

0 Likes
Rocatah
Explorer
Options

Hi again..

I've resorted to doing a factory reset on my phone, and... Same problem, will only connect for chargingonly. (USB debugging is checked and Transfer files selected...

Thanks

0 Likes
smg1
Helping Hand
Options
You have to set USB DEBUGGING for any computer to see your phone. Just enter that into the search in settings and make sure this is enabled
0 Likes
Rocatah
Explorer
Options

Hi

USB Debugging is enabled.. 

0 Likes
smg1
Helping Hand
Options
Oh right...is your cable a data cable or just a power cable?
0 Likes
Rocatah
Explorer
Options

It's a data cable. I have another phone (huawei) which connects with this cable with no problem, with pop up showing immediately..

Thanks

I just tried it with my other computer..it does the same thing..

0 Likes
Tourbillon De La Vie
Samsung Members Star ★
Options

I would try with another cable. For some reason huwei one is not working. One more thing if you have a  mobile case on just check you are plugging it in fully 

0 Likes
Rocatah
Explorer
Options

I've tried with 3 different cables.. all the same. Also tried with the case on or off.. again same thing.. It is definitely phone related.. 🙁

0 Likes