Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Galaxy S22 Ultra language randomly changes

(Topic created on: 13-09-2022 06:55 PM)
ThoughtEater
Journeyman
Options
Galaxy S22 Series

I have had this new phone for only three days.  The issue began on day one, before i installed apps.  Sometimes while texting, if I use an exclamation point or other symbol, it is in another language.  The exclamation mark on the keypad is proper, but the types mark in the text is upside down, and dollar signs are converted to Euro signs.  Up until today, if I go to Samsung keyboard settings, then Languages and types, then tap English Qwerty, then tap Qwertz, then tap it back to Qwerty, it reverts back to English (US) symbols.  But today while compsing a text the first exclamation mark i typed was proper, but later in the same text message I typed another exclamation mark and it was put upside down.  The Qwerty toggle trick noted above did not work.  I had to go to system languages, switch to spanish, then back to US English for it to allow me to finish my text message in English US.  Is there a way to fully uninstall all languages other than English US so it has no other languages to switch to?  This is driving me bonkers!  I definitely cannot keep this phone if I cannot control what language it operates in, but I have only a few more weeks to rescind the purchase.

 

0 Likes

1 Solution


Accepted Solutions
Solution
ThoughtEater
Journeyman
Options
Galaxy S22 Series

I accidentally solved the issue yesterday. If I quick-tap the keys, I get ! and $ as expected. But if my tap is more than two nano-seconds it gives upside down ! and euro money symbol instead.  The strange thing is when I first encountered this issue the first thing I looked at various language settings, and nowhere did I see any second language configured.  Anyhow now I know how to work around it it... quick-tap!

View solution in context

0 Likes
5 REPLIES 5
Neo001
Maestro
Options
Galaxy S22 Series

HI @ThoughtEater,

¡Very strange issue! :winking-face:

In Settings > General Management > Language, select your default language. If multiple languages are selected, you could remove all but English. Next click on Keyboard list and default. Click on Samsung Keyboard > Languages and types > Manage input languages > toggle every other language, except English.

If none of this work, then download Gboard (Google Keyboard) and give that a try. 

0 Likes
ThoughtEater
Journeyman
Options
Galaxy S22 Series

Thanks for your quick suggestion, Neo!  In Settings > General Management > Language there is only one language - English (United States), with a number 1 to its left and a checkmark to its right, and underneath is 'Add language.'

In the Keyboard List and default, it shows Samsung Keyboard (Languages and Types is set to English (US) and autoreplace and Suggest Text are both set to same), English (US).  In Manage input languages, all are off except for English (US).  As advised, I toggled all languages on then off, but left English (US) on.  Will see how it goes!

ThoughtEater
Journeyman
Options
Galaxy S22 Series

...also, for good measure, rebooted the phone.

0 Likes
ThoughtEater
Journeyman
Options
Galaxy S22 Series

Well, for a few days it was ok, but just now while replying to a text, the language again changed itself to spanish. So I went into keyboard settings, changed it from qwerty to qwertz, then back again to qwerty, then returned to the text i was composing, and the language was English again.

This is very annoying!

0 Likes
Solution
ThoughtEater
Journeyman
Options
Galaxy S22 Series

I accidentally solved the issue yesterday. If I quick-tap the keys, I get ! and $ as expected. But if my tap is more than two nano-seconds it gives upside down ! and euro money symbol instead.  The strange thing is when I first encountered this issue the first thing I looked at various language settings, and nowhere did I see any second language configured.  Anyhow now I know how to work around it it... quick-tap!

0 Likes