Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Messenger(facebook) alerts not working S21 Ultra

(Topic created on: 08-10-2021 07:02 AM)
illEez
Voyager
Options
Galaxy S21 Series
Hi. Hoping someone can help!

I've set everything up correctly, but am not receiving alerts for messenger messages half the time.

They appear on my A7 tablet no problem, which is in the same room connected to the same WiFi, but I only get them sometimes on my S21 Ultra(usually delayed relative to my tablet)which is beginning to annoy me!

I'd expect the S21 to outperform my tablet with such a basic task, but here I am.

I have the S21 set up to receive notifications on lockscreen, but it rarely does; is there anything I can do to alleviate this, or does the phone simply not allow them despite its settings suggesting otherwise; it happens when I'm browsing or using other apps too, but again, I have no problems with the tablet under the same circumstances.

Thanks in advance.


0 Likes
6 REPLIES 6
kirito39
First Poster
Options
Galaxy S21 Series

I'm facing the same problem...No notifications of messenger as well as Gmail. WhatsApp and other social apps notifications are working fine.  

0 Likes
illEez
Voyager
Options
Galaxy S21 Series
https://youtu.be/vgjYp8w9rVE

I'm hoping this helps!

About 2m30+ seconds in...

Basically do this:

Settings:
Search - 'Optimise Battery Usage'
Select - 'Apps Not Optimised'
Select - 'All'

Scroll through apps and deselect/uncheck the apps giving you problems 🤞
0 Likes
illEez
Voyager
Options
Galaxy S21 Series
Could also try

Device Care - Memory - Exluded Apps - add Messenger etc to excluded apps, though I can't see Gmail on my list of possibilities to exclude, so I opened Gmail, went back into settings(same as above steps) and Gmail appears in the 'Memory' section now, so I deselected it there.

I set my processing speed to 'High'

Switched Adaptive Battery 'Off'

Power Saving Mode - Off

Background Usage Limits:
Put Unused Apps To Sleep - Off

...and for the past few messenger and emails I've got alerts through straight away on both the S21 and my tablet at the same time...hopefully that's sorted it...

...if it plays up again, I'll try switching 'Auto Optimise Daily' - Off.

Unreal amount of settings on these devices 😅
0 Likes
illEez
Voyager
Options
Galaxy S21 Series
I just switched my messenger app to use mobile data only, seems to be working fine off that, and has only burnt through just shy of 2MB over the past day.
0 Likes
Jeffrey13
First Poster
Options
Galaxy S21 Series

Hi, I've had the same issue.

I've had a play around with the power saving mode settings.

That seemed to have fixed the issue.

Setting, battery and device care, battery, power saving mode set to off.

Hope this helps

illEez
Voyager
Options
Galaxy S21 Series
Thanks but I got it sorted a while ago using one of settings I listed here; think it was just switching the app to use mobile data only that fixed it for me.
0 Likes