Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Screen stays dark when notifications arrive

(Topic created on: 03-07-2022 03:54 PM)
Baldfinger
Apprentice
Options
Galaxy S20 Series

I have made all the software updates, but still, when I receive a notification (whatsapp, signal, anything except SMS) the phone vibrates as expected but the screen remains dark.

I have to manually double tap the screen to activate it and see the notification. Which is unbelievable, but I have checked with another person who has an S20 as well, with the same behaviour. Always On Display doesn’t solve anything (and drains battery).

I juste cannot imagine that such an expensive phone isn’t able to turn on the screen to show my Whatsapp notifications when they arrive. And yet I’ve tried everything I could find on the forums, all my settings seem correct, and again, it’s working for SMS (built in messages app) but no other app.

Has anyone been able to resolve this and get all their notifications to light up the screen on reception ? (Without AOD!)

Thanks a lot for any help!

4 REPLIES 4
Richmar83
Helping Hand
Options
Galaxy S20 Series
Have a look at these within the settings & make sure the apps are included and that brief pop up settings says 'when screen is off'.
Also, double check you've not got do not disturb on.

These are my settings and I don't have AOD on. I just get the pop up notification and screen edge strobe.20220703_171110_11031_1656864670.jpg
0 Likes
Baldfinger
Apprentice
Options
Galaxy S20 Series

Thanks a lot for the quick answer! 
This seems indeed to allow for the brief notification to show, which is an improvement. 
But I would like to be able to see the actual notification, meaning the « detailed » one. When I select detailed, the included apps and pop up settings disappear. Any idea how to get the screen to turn on and show the full notification ?

thanks 🙂

0 Likes
AndrewL
Moderator
Moderator
Options
Galaxy S20 Series

@Baldfinger: Can you try heading to Settings > Lock Screen > Notifications > Details > Hide content > Off > Notifications to show > Alert and silent notifications. 

Now, head to Settings > Apps > WhatsApp > Make sure all relevant notification options are toggled on > Group notifications > Show as pop-up (On) > Lock screen > Show content. Go back and apply the same settings to Message notifications, and let me know if this helps. 

0 Likes
Baldfinger
Apprentice
Options
Galaxy S20 Series

Hi Andrew, thanks for the help.

Unfortunately it doesn’t change anything. The screen lights up to show just a short bubble and the Edge lighting thing, but on black background, and it’s only possible with the brief notification, if I change to detailed, nothing’s happening again. 

Whereas what I’d like is for the screen to completely turn on, show the background and biometric unlock icon and clock and everything, with the detailed notification, like on any other phone I’ve ever used. 

I think I’ve run out of options to try out, and am just in disbelief at this stage. Gonna save up for an iPhone :face-with-tears-of-joy:

 

Cheers!

0 Likes