Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

USB OTG camera can't switch to controlled by this device

(Topic created on: 3 weeks ago)
alhobo
First Poster
Options
Galaxy A Series

I'm attempting to connect my camera via usb otg to my Samsung A41 so I can use it as a monitor and control some settings externally via an app.  I have no problems connecting and using it this way with my wife's motorola phone or my son's samsung J5 and his tablet. 

But when I connect to my A41 the usb connection comes up ok, but it won't let me change the USB settings from 'USB controlled by connected device' to this 'device' and therefore I can't connect the camera properly.  It connects for a second or 2, and then reverts back and says 'can't switch.'

I've noticed that when I plug in the camera I get a notification saying that a media device is connected.  I get no options to select it as a camera, rather than a media device though.

I've been into developer setting and tried everything there - setting the default USB settings to transfer images and enabling USB debugging - but nothing makes a difference.  I'm still unable to change to 'USB controlled by this device.'

I've tried various different cables and cleaned the USB port - but nothing has worked.  The fact that it works with other phones and a tablet makes me think that it has nothing to do with the cables.

Any help would be much appreciated. Thanks.

0 Likes
0 REPLIES 0