Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Battery Saver mode / Gmail notifications

(Topic created on: 21-05-2021 09:45 AM)
12440 Views
tommo800
Apprentice
Options
I'd be interested to hear if anyone has the same issue....
I use the battery saver mode often on my A51, I see a real noticeable difference in battery life, enough so that I'm happy to forego a few of the features of not having it on (always on display, etc). With one exception, and that is that my Gmail push notifications don't come through. This is a pretty big deal and it's very frustrating. Does anyone else have the same issue, or know of a workaround? Thanks
6 REPLIES 6
Peter918
Explorer
Options
I have the same problem I think it's the Gmail app not battery saver mode. I have put my Gmail account on Samsung mail app and I get notifications no. Problem.
0 Likes
AndrewL
Moderator
Moderator
Options

@tommo800: Can you try heading to Settings > Battery and Device Care > Battery > Background Usage Limits, and check to see if Gmail is in your Sleeping or Deep Sleeping apps? If it is, tap the 3 dots in the top right > Edit Apps > Gmail > Remove. Also, head to Settings > Apps > Gmail > Notifications > Email > Set your preferences> Back > Miscellaneous > Set your preferences > In-app Notification Settings > Check your available options here. 

LL05
Apprentice
Options

For android 12 just go into settings - apps - gmail app - battery and select unrestricted

Members_Pifry5n
First Poster
Options

Can confirm this works also on Galaxy S22 - go to Settings -> Apps -> Gmail -> Battery and select unrestricted.

No need to put gmail under "never sleeping apps" under Settings -> Battery & Device Care ->  Battery -> Background Usage Limits. The above setting for the gmail app alone works well.

Jaykishan Vaghela
Apprentice
Options

Hi All, I found this solution after doing research (I have Samsung S20 FE 5G)

Go to Settings -> Find Apps Click on Apps -> Find Gmail Application Click on Gmail Application -> Click on Battery -> Select Unrestricted 

😀Now you will get a Notification 

 

Thanks

 

 

pg94au
First Poster
Options

Setting gmail to unrestricted battery usage does not really solve the problem.  I have had this option set since I got my phone, and it's obvious when other android devices (my old phone, other tablets) play alerts when new email comes in and my S22+ does not.  The alert will eventually come, but it is not timely.  Turning on the screen (sometimes) or opening the gmail app after you already know an email was received (by other means) will cause it to alert immediately or show new messages if they haven't been read yet, so there is still some interference with the app's normal operation where it isn't running but will as soon as you intervene manually.

0 Likes