Support

Open search

A7 - No MTP connection after Pie update

Highlighted
Explorer

Have been through everything, including different cables and computers. Set developer options on and USB to transfering images. Also used *#0808# to set to MTP there. Nothing worked - phone just charges.

 

Got on to Samsung chat to find out the MTP option has been removed. This is now an ongoing case and I am awaiting a phone call on the matter. Only purchased the phone in February and they have changed something which I based my purchase decision on. As an analogy, you wouldn't buy a car which then had a software update sometime later which meant you could only use it in daylight hours!!

 

Can anyone who has an A7 and has updated to the latest Android version (got mine last week), check if they can connect to their laptop / computer and confirm that there is no longer an MTP (or any other option!!) - phone merely charges.

 

Many thanks.

13 REPLIES 13
Highlighted
Voyager
Hello!

From the dialer on your device, enter *#0808#

USB > select AP

USB Settings > select > MTP + ADB

Or enabled the MTP at Developers options

Go to Settings > About Phone > Software Information > tap Build number 7 times until it says "You're now a developer"

Back to Settings > Developers options > open USB configuration > set to MTP or File Transfer

Reboot your phone to take effect if needed.

Thanks ^_^
Highlighted

Hi,

 

many thanks for the reply. However, as detailed, all of this has already been actioned (exception that set to transferring images rather than files). As a double check, I actioned this too ...still the same.

 

I have been told earlier via Samsung that the software release was the issue (but then they started to backtrack somewhat once I outlined the consumer position), hence my eargerness to find others in the same predicament.

 

 

 

 

Highlighted

For anyone else who reads this / has the same problem, after many, many hours on chats and phone calls with Samsung, let alone trying various potential solutions including a full factory reset, all they will do is put in a development request to resolve the issue in some future release (not timescale!!). 

 

I will not rest this case until resolved and will progress now legally. As MTP was part of the reason for purchase, the removal is in breach of contract. If a (defined and reasonable) timeframe could be given on a fix, that is a different situation and is perfectly legal / acceptable. As no offer of a refund, replacement (of a model of at least equal specification and value) or a date for a fix has been offered or provided (and the phone is still well within its warranty period), then they are in breach.

 

Samsung will state that it is only they hardware which is covered, this is not the case. As an analogy and example, if one purchased a car which was meant to work 24 hours a day and suddenly a software update limited that to daytime use only, then I think the courts may just come down on the side of the consumer!!! 

 

As many companies, Samsung seems hell bent on trying to discharge their duities after a sale. This could have been a fairly simple 'fix'; they have chosen not to make it so unfortunately. Personally, I will not be beaten or downtrodden and will continue for a long as it takes.

Highlighted
Pathfinder
I have a A8 2018 with pie (which has the same internal specifications as the a7 2018) which still has the option. Maybe Samsung only kept it on pie for the usb c devices as the a7 is micro usb, but if it had it before I don't see why they would do so. Hopefully it gets fixed soon by a software update
Highlighted

Thanks for the information - appreciated. It's only an A7 thing as far as I am aware. Heard nothing further from Samsung, so will start a case against them in due course. Even if they could give a defined (and reasonable) timeframe for the fix, they would still be within their rights; as they are unable to do so and will not refund or replace with a working model, they are in breach. As I state, I won't let this go!!

Highlighted
New Member

I have a Note 8 (US, unlocked) that has been upgraded to Pie. I am on the January 2020 security patch. MTP works when fprced using the *#8080# method.

Highlighted

Many thanks for replying, especially after all this time. Unfortunately the *#0808# does not work (tried originally). Hopefully the latest Android update (April rollout in the UK I believe) will resolve. Started to look at other phones now too as Samsung really disappointed me with this - such a shame.

 

Once again, thank you for your time - appreciated.

Highlighted

Olá Boa Noite.

Estou enfrentando o mesmo problema após a atualização do sistema operacional da Samsung (J7 Metal 2016 "SM-J710MN" - "Versão Android 8.1.0" - "Versão Samsung Experience 9.5" - "Número de compilação: M1AJQ.J710MNUBS4CSL1" - "Nível Patch Segurança Android: 12/01/2019 "), em 2 telefone iguais ao meu após atualização pararam de funcionar aqui na empresa, os demais que não foram atualizados permanecem funcionando perfeitamente.

Highlighted

This does not work. I select file transfer but phone is still not seen. Original Samsung cable. Phone charges.

Top Liked Authors