Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

A54 not registering on O2 network on wifi calling

(Topic created on: 15-04-2024 05:28 AM)
262 Views
Desktop
First Poster
Options
I live in an area with no mobile signal. I bought an A54 from Argos and took out a contract with O2. Wifi calling works until my phone reboots. Then the O2 network is lost and I have to drive 2 miles to an area with an O2 signal to register on the network. It then works until the next reboot. I have had 3 months trying to get O2 support to fix this but after trying everything suggested I'm in the same place. O2 initialy blamed the Broadband service, but it's same when I try on friends Sky WiFi connection. Friends can reboot their phones on my Vodafobe broadband wifi connection and make calls. After several calls from the so-called O2 guru the blame was laid on my A54. My wife has an A51 on O2 and has the same issue. Anyone else had this?
0 Likes
3 REPLIES 3
BandOfBrothers
Samsung Members Star ★★
Options

I'm sorry to learn your experiencing these issues 😔 

If you've also spoken to Argos, what has Argos said who supplied the phone to you ?

I haven't owned that mid range model of Samsung phone unfortunately so cannot share my experiences with that model. 

The contract with o2 may I assume is a monthly contract as your using Wi-Fi Calling. 

I use o2 Pay as You Go  and cannot use that service. 

However there are other networks I believe that let payg users have Wi-Fi Calling.

I would have used one of those so not to be locked into a contract that I can't use at home. This is in no way criticism directed at you.

It's possible the phone struggles to provide a connection if there is not a hint of network connection to then instigate Calling over WiFi unfortunately or it's an o2 sim problem that won't allow it. 

If I can be of any further help then please don't hesitate to ask.  😎 


Daily Driver > Samsung Galaxy s²⁴ Ultra 512Gb ~ Titanium Black.

The advice I offer is my own and does not represent Samsung’s position.
I'm here to help. " This is the way. "

0 Likes
Robin999
Black Belt 
Options
In addition to the excellent advice from BandofBrothers and this is reliant on a strong wifi connection.

Settings>connections >tap wifi calling>tap 'calling preference'>ensure 'wi-fi preferred' is ticked.
0 Likes
Desktop
First Poster
Options
Thank you. We tried everything O2 support and others suggested to no avail. Friends who have visited the house have tested with a number of different combinations of phone and service provider and all work okay.
0 Likes