Support

Open search

A51 4G not working

Highlighted
First Poster

Hello iv recently gone from a s8 to a51 but the 4g dosnt work i have been though all the settings all are correct for 4g. Sometime After restarting my phone a couple of time i can get it on and it will stay on untill i use wifi and then turn wifi off it wont connect to 4g. 3g works fine when i go to 3g/2g only. Anyone had this fault? 

10 REPLIES 10
Highlighted
Superuser I
Superuser I

Does this happen everywhere or in a particular place @Lil_chris 

It might be worth checking in any available Network Status Checker to look for mast issues.

 

As a process of elimination can you try your sim card in another phone and another sim card in your phone ?

 

You could also try resetting the network settings on your phone.

 

Unfortunately you can't yet go to a Samsung Experience Store or Samsung Service Centre as they are temporarily closed due to the COVID-19 pandemic.

 

I wish you all the best with this situation. 

 

🌈 Stay Safe  🌈 

 

 

My advice comes from being a UK Samsung Phone Owner.
I have no affiliation with Samsung.
Current Phone ~

Samsung Note 10 Plus 5G _256Gb >_ Samsung One Ui 2.5/ Android 10.

Highlighted

thank you for the reply it happens everywhere and iv tried sim in my s8 works fine and tried another sim in this one same result. I think its the phone at fault 

Highlighted
I am having the same problem with my A71.
Highlighted
Im sorry you have the same problem but slightly happy its not just me. If you find a solution please let me know thanks
Highlighted
First Poster

+1, I'm having the same issue

Highlighted
I sent mine back and got a full refund instead.
Highlighted

Me too..not happy. Tried every scenario...Clean sim, new sim, wife’s sim on same network doesn’t work in A51 but works fine in cheap & cheerful J3, factory reset, switching to flight mode then powering off etc.... Next step the ***** thing could very well be entering orbit. Waste of Money. Fix this Samsung it,s very poor

Highlighted
New Member
I am having similar problems with my A51. Sometimes 4g connects and other times it doesn't and I have not detected any pattern in it.
Like Ian72, I've tried a different sim and a different phone. Very annoying.
Come on Samsung, let's hear from you.
Highlighted
New Member

I am having the same problems with my A51. The phone loses its 4G connectivity everytime I go out of the house. After restarting my phone it works again.. for a while. 

When I use an onder model (A50) I am not having any problems with the same SIMs and the same apps and settings (Back-up). 

The store is not willing to help anymore (After 2 times) because they can’t find the problem. The phone is new since mid March and I noticed having problems since April! Please fix this Samsung!