Support

Open search

portable blu ray writer Model SE-506, firmware update and windows 10 driver needed

Highlighted
New Member

Dear Sirs,

 

I have change the operating system of my PC from Windows 7 to Windows 10.

 

When I connect the portable blu ray writer Model SE-506 via USB I can work with CDs and DVDs. But Blu Ray discs are not being recognized anymore.

 

It seems that the player is not compatible to Windows 10 at all.

Where can I get a driver for Windows 10 and if needed a firmware update?

 

Many thanks,

Alex

 

142 REPLIES 142
Highlighted
First Poster

Same issue. It has been a while and I can see no answer has been given, should we give up and buy a new one? In my case it won't be a Samsung one, of course. Samsung, at least be honest and transparent with your customers: are you really willing to fix this or not?

Highlighted

I've just bought a Mini Mac, when I plugged the BD player/writer didn't work. While looking for a solution (possibly the phantom drivers nowhere to be found), I found the suggestion of trying with a double USB. So did I, and by magic, it is working!

Highlighted

Just spent several hours trying to get my three year old Samsung SE-506 blu ray writer to work with Windows 10 when I googled this website and found that the writer does not work with Windows 10 and that Samsung does not appear to be interested in supplying an updated driver.  SO I am off to buy a new blu ray writer - needless to say it will not be a Samsung.

Highlighted

Same problem with my SE-506BB drive.

Highlighted
I ditched the USB cord that originally came with it and purchased a new cord that was compatible with "USB 3.0". When I plugged it in, it initiated the DVD program that comes with imac's and worked just fine. The cord compatible with USB 3.0 made the difference.
Highlighted

Its for sure the cable on Windows 10, not entirely sure how that's possible but I'm the third person who has had this be the fix.  I'm fairly confident it's the solution.  

 

This is the cable I am now succesfully using.  It's $6 on amazon, not a perfect solution but good enough for me.  This drive was not cheap when I bought it. 

 

https://www.amazon.com/gp/product/B00NH11N5A/ref=oh_aui_search_detailpage?ie=UTF8&psc=1

Highlighted

Moderators

 

In a previous post I mentioned that I tried the split power lead that I was sent by the Samsung support, in order to increase the power supply to the drive, but it made no difference. Now it's being reported that if indeed a single power cable that is specifically designed for USB 3.0 is used, the drive works. Does Samsung realise this and if so, why was I not sent such a cable to see if it fixed the problem?

 

Regards

Highlighted

Hi guys.

 

Very interesting that a USB 3.0 cable appears to resolve the issue - and thanks for trying it out and letting the Community know how it went. I've added your posts to the ongoing escalation/investigation we've got on this.


 Say "Hello!" to the Community in The Introduce Yourself Thread.


Highlighted
I’ve been having this issue as well. But wanted to share... I found an old cable laying around - plugged it in and problem resolved.
Highlighted

@marksung: But this is not a USB 3.0 cable?

Top Liked Authors