Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

HW-Q90R soundbar does not pass through Dolby Vision HDR signal

(Topic created on: 04-05-2020 07:30 PM)
3833 Views
abc123xyz
Explorer
Options

Update:  I can get Dolby Vision passthrough now! You simply have to turn of the HDR10+ functionality on your Panasonic OLED: TV Settings>Setup>HDMI HDR setting>HDR dynamic setting>HDR10+ Functionality = off

 

I tried to connect my Apple TV 4K (ATV) to my HW-Q90R soundbar to pass through a Dolby Vision HDR (DV) signal to my Panasonic GZ1000 TV. I have also tried this with my Xbox One X (XB1). I was using the Netflix and ATV+ apps. Both devices fail to pass the DV signal through my setup and all I get is HDR10. However, I have read that others have had success passing a DV signal through. I have checked all my settings on all the devices in the chain and they are correct. I am using ultra high speed 8K 48Gbps HDMI cables.  I have also tried connecting the sources directly to the TV and then DV does work.  The problem is then I get really bad lip-sync issues when passing the sound through the TV to soundbar, which eliminates this setup as a solution. I am posting here to hopefully get some feedback from other people who have either successfully passed an ATV or XB1 DV signal through their HW-Q90R and also those that have failed to do so. I am interested to see what TVs, video sources and apps you are using, especially  when using ATV or XB1. I find it very frustrating  and annoying that two common sources can't be used with their optimal video signal considering that the HW-Q90R is Samsung's flag ship soundbar.

0 Likes
23 REPLIES 23
Josephk
First Poster
Options

Hey guys, 

 

So I've gotten the splitter now, and I guess it sort of works. Kind of buggy to be honest. 

On the other hand, I've been connecting the Apple TV to my other HDMI ports. Surprisingly, I do not get any audio sync problems. DV on the display and Atmos on the soundbar through ARC, the whole shebang. I am as confused as you guys, now that it works on its own

I suspect the problem on audio sync comes up when we are trying for 4K @ 60FPS with DV. I am currently watching content with ordinary 4K @60fps and DV4K@24fps with no audio issues. 

Can anyone confirm? Soundbar is on the latest 1008 firmware. 

0 Likes
zackes
First Poster
Options

error

0 Likes
abc123xyz
Explorer
Options

@Facakente wrote:

Hey there ,

 

did u manage to resolve this or is that not possible ? I came along with same problem , I am unable to pass DV signal to tv , I only get HDR , I have a similar setup I have the gz950 - hwQ80R - ub820 


Success! I can get Dolby Vision passthrough now. You simply have to turn of the HDR10+ functionality on your TV.

TV Settings>Setup>HDMI HDR setting>HDR dynamic setting>HDR10+ Functionality = off

0 Likes
Facakente
First Poster
Options
Hey mate, yes u are right.
I tried and it works.

Now was this always like this ? Because today I just updated firmware . But I tried previously with new firmware and it wasn’t working .
0 Likes
abc123xyz
Explorer
Options

@Facakente wrote:
Hey mate, yes u are right.
I tried and it works.

Now was this always like this ? Because today I just updated firmware . But I tried previously with new firmware and it wasn’t working .

Good question. I tried this yesterday before the soundbar got its firmware update and therefore that update had nothing to do with it. Anyways, I'm really happy it worked now. Enjoy!

0 Likes
scottahm
First Poster
Options

The solution worked for me too (q70r soundbar). However I'm not too happy with the solution, what about HDR10+ content from other sources?? I guess the setting would only effect other HDMI sources... eg My Chromcast Ultra? Hell I don't even know if CC Ultra supports HDR10+ in the first place 

0 Likes
Largo1
Journeyman
Options

Great news it works!

0 Likes
Gil80
Pioneer
Options

I use an LG OLED CX which doesn't support HDR10+, but does support DV.

My nvidia shield is connected to the Q90R. 

I can't get DV working. I only get HDR label instead of DV when I play DV content. Quite a bummer.

0 Likes
Facakente
First Poster
Options

It should work , as I know people with c9 and DV signal is passed.

 

check your cables , might be a problem with a cable , anyway u get hdr , so I don't know cx settings , but in Panasonic I had to disable hdr10+ in the tv settings , maybe cx has some setting causing this behavior.

0 Likes
Gil80
Pioneer
Options
The CX doesn't support HDR10+, only DV and HDR. Since LG supports only DV, it will never support HDR10+.

I couldn't find anything in the settings of the TV.
However, if I play DV content via TV's netflix app, the TV will display a DV label on the top right corner. If I play via Nvidia Shield I get HDR labels instead.
0 Likes