Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

HW-K950

(Topic created on: 03-03-2018 05:05 AM)
2096 Views
Mcguckind
First Poster
Options

This is a great piece of kit, sound amazing with an Atmos 4k disc

 

However!! At least once a day the wireless surround speakers will not connect, sometimes switching it on and of about 10 times works. But more often you have to manually reconnect the system. This is frustrating, and for a product costing £1,200 I don't think this is acceptable 

 

any help would be gratefully appreciated 

 

david

0 Likes
3 REPLIES 3
cjcornish7
First Poster
Options

I too am having an issue with the surround left speaker.

 

It lost connection a week ago and now is permananently flashing blue.

 

I went through the manual setup which didn't work and now I cannot get into the ID setup on the soundbar after holding the volume button down (nothing happens anymore).

 

I have tried placing the speaker next to the soundbar, unplugging everything but still nothing.

I have the latest firmware update.

 

Is there an option to do a full system reset?

0 Likes
LennyH
First Poster
Options

I have the same issue. Wireless speakers worked with the soundbar for about year, stopped working at Christmas, never been able to set them up again. Blue lights flash continuously, can't stop that happening even turning all speakers off and on again, have left them unplugged, still no difference.

0 Likes
Wolfydog
First Poster
Options
When use netflix on pc with my soundbar k950 it turn black and blinks twice and the all black with sound. Whe use teamviewer, i can see netflix running with image and sound.
Please help me
0 Likes