Support

Open search

Anynet/HDMI-CEC and ARC not working

Apprentice
Hi there,

I have this problem for over a month now.

I have a Samsung TV model UE49MU8005 connected to a Pioneer Receiver model VSX-LX302. Everyhting is well connected, as far as i know, TV firmware is 1210.8.

Tv is connected through a recent HDMI cable (UHD, ARC, etc etc) from the ARC output of the receiver to the ARC input of the TV (HDMI 4). Anynet is on.

When I disconnect the cable and connect it again, it starts identifying the source on the TV and it always says "unknown source" so i have to manually configure the tv remote. After it detects my Receiver, turns it on and off ok, and finishes the connection. Everything seems ok. But the problem starts here:

- The sound does not come out through HDMI from the TV if I select an app from the hub. Neither it does if it's connected to the antenna of the tv.

- I have sound from the cable box and from a PC both connected to the receiver.

- The receiver has CEC on but it the sound is not there. When I disconnect the CEC on the receiver and connect it again, it starts searching for CEC devices but the answer is "no CEC device"! Although the TV is connected of course..

- Anynet stops working too, it doesn't control my receiver when this is happening.

- This bug goes on and off. It works sometimes, other times it doesn't. It seems that theres is some problem in the TV that disconnects automatically HDMI CEC, and then it just doesn't come back.

- I changed cables, update firmwares, disconnected everything and waited, then connected again, called Samsung support and they just don't seem to know what I'm talking about... The problem always persist.

Frankly, I'm considering returning the TV. It's new and for the price it should NEVER cause such hassle.

This is about something that should work perfectly and is not doing so. And it seems that everyone at Samsung knows the problem exists, they just don't know how to solve it... (according to the countless discussions about this topic, at least at the US community..).

Please help!

Regards

288 REPLIES 288

My TV and Receiver worked well together for 2 years until I had to unplug the TV today. Then all hell broke lose. This morning I could control everything... Receiver and Firestick with my Samsung remote. Fast forward to this afternoon and now I have to use the Samsung remote to turn the TV on and the receiver remote to control volume. This is absolutely ridiculous. I paid good $ for this isht. I should work right 100% of the time. 

Yeah, this didn't work with this cable:

https://smile.amazon.com/dp/B07VMD11JZ/ref=cm_sw_em_r_mt_dp_U_vSbpEbG9YDYP6

between an Onkyo TX-NR585 and a Samsung QN49Q6F. ***** around with it for an hour. Went through the setup process on the Onkyo, and it just hung up when it got to enabling ARC.

I have the same issue with js8000 and onkyo 626

everything was working perfect for 2 years straight. 

lost connection, after 2 hrs trying to fix it, unplugging the tv and replugging the tv fixed it. 

1 year later, same problem...  nothing seems to fix it anymore. 

 

changed hdmi wires,  tried setting up arc with ONLY tv and receiver plugged in, nothing works. 

super disappointed, especialy after the premuim price tag i paid for this TV.

From my experience:
Unplug everything. Switch off power.
Plug in every device....and wait...wait...5 minutes minimum. Then you can power on your TV. It should communicate with HDMI-CEC/Anynet

I am afraid your wrong with the Samsung TV and soundbar from Samsung. I am having the same problem as others.

I found out the other day that my TV box was causing the problem with the ARC connection stop working. Apparently the Cisco box is CEC noncompliant.

 

I just bought a HDMI switch box and see if that will work.

 

I will post my results when I try it.

Well I changed my Telus TV box to the new 4k TV box and now my ARC works fine! I also upgraded the internet at the same time.

Fantastic news soundlover!!!

 

I have been having all the issues listed in this forum on my new 82Q60R with one additional solution tried per the advise of samsung support. That being to add another hdmi cable to hdmi 4 ARC on my tv and connect it back to hdmi 1 in on my Anthum MRX 720. Well no surprise that that did not work either. So that being said and after nearly an hour on the phone the tech said she needed to look into this furthor and email me in the morning. After reading many posts about this issue, I am not at all comfident that she will return with a fix. I also have a Logitech Harmony Elite remote and am going to program it to the new tv. I would be interestred in more details on how you set yours up if you are still on this forum or if anyone else knows what "he " programmed into his Harmony remote.

@all

if you are still experimenting issues with your TV please try to change the following setting :

 

Settings / General / External Device Manager /  Input Signal Plus

 

In my case I had a device that was causing my entire setup to be silent due to an incompatibility with the CEC / handshake EDID whatever.

 

so  turn out that my setup box needed the input signal plus to be disabled. But since I needed this setting to output HDR I simply disabled the PIN 13 on the HDMI socket from my setup box. I opened up this junk and cut the trace on the circuit board.

 

i hope this will solve problem for some of you.

 

 

 

Ever since I removed my Chromecast Gen 2 my soundbar never disconnects anymore, why would a Chromecast not be CEC compliant? It's literally built to use it

Top Liked Authors