Open search

Gear watch weather failure challenge!

First Poster

Hello All, 

I bought a new gear watch 46 mm. Unfortunately, the weather app didn't work on my gear watch since day one. I installed all updates in vain.  So far, It hasn't even opened once. Every time I open the App menu and click the weather,  a submenu opens with location and settings but whenever I click on either of these two to setup the weather, it just sends me one step back to the Apps menu. No messages, no settings, Nothing! Just back one step. I tried uninstalling and installing 3 times  resetting the watch, the connections,, etc but I always end up with the same result. Any thoughts? I'd really appreciate any ideas or advice to help me solve this challenge.

Thanks in advance.

AndrewL Moderator
@Johncruez: I've had a look into this for you and can see that the Weather app on the Galaxy Watch requires you to set a location on a connected mobile device, therefore if you are using the watch by itself then it won't be possible to utilise the app. Apologies for any inconvenience this may cause.
First Poster

Hi Andrew, 

I really appreciate that you took the time to look at my problem and provide a solution. FYI, I'm using the watch in conjunction with a mobile phone that's already set to a location and I have the permission for location turned on for the gear wear app. Any further ideas?

Thanks a million 

Top Liked Authors