Support

Open search

Galaxy Tab S3 Screen Miroring Problem

First Poster

I hope someone can help me with this.

 

My new Galaxy Tab S3 does not sceen mirror!!!

 

I have tried it with my Samsung TV model UA40KU7000KXZN and it did not work!!!

 

I have tried it with my WD TV, which has a screen mirroring capability and it did not work!!!

 

I tried to screen mirror my Galaxy Note 5, and it worked with both in no time. I think the problem is with the tablet.

 

This is how I do it:

 

I open the top menu, tap smart view and the select my Samsung TV or WD TV. This works with the Note 5 and always fails with the new Tab S3!!!

 

Every time I try to screen mirror my Tab S3, it takes some time to find the TV and then it fails to connect.

 

I am so confused. This is supposed to be Samsung's premium tablet. So why it does not work as expected. My 2 year old Note 5 works better than this new Galaxy Tab S3.

6 REPLIES 6
AntS Moderator
Moderator

Hi @Hani_Marouf.

 

Have you checked the tablet's Wi-Fi and connection to the Wi-Fi network the TV's on? The Smart View app works via Wi-Fi, and so if the tablet's got issues in that area it may account for it not mirroring to your TV.

 

If everything's fine in that department, then it would be worth checking the Smart View app's permissions on the tablet and making sure everything that needs to be enabled is:  Settings > Apps > (3 dots) > Show System Apps > Smart View > Permissions.

 

According to the app's PlayStore listing:

 

Required Permissions:

Storage: Required to access the local photos, music and videos on your phone to cast to TV from the app
Wi-Fi: Requires Wi-Fi access to send contents on the phone to TV
Phone Status: Required to check if network is connected
Internet: Required to connect to external content server

Optional Permissions:

Location (Coarse): Discovers TVs in proximity (2016 and 2017 TV models)
Bluetooth: Needed to turn on TVs in Stand By mode (2016 and 2017 TV models)
Record Audio: Needed to send voice commands from the app to TV
Vibrate: Needed to provide tactile feedback when using the app
Wake Lock: Needed to prevent the phone from sleeping while using the app


Prince_Community_Sig03.jpg

 Say "Hello!" to the Community in The Introduce Yourself Thread.


First Poster
Hi Ants,
Thank you so much for the reply. I have checked the Wi-Fi and it was working fine.
Tried to review smart view app permission as you explained, it says under app permissions "no permissions required" and it seems that permissions for this app are automatically activated.
I noticed that when I open a video or a photo and share it with the tv, it works, but unfortunately screen mirroring which allows me to view my tablet screen on tv still not working!!!
Maybe telling you that I purchased my tablet from USA would help. Maybe there is specific settings for USA tablets I need to check.
Thanks.
AntS Moderator
Moderator

No worries, Hani_Marouf. 

 

If the tablet's firmware is fully up to date - and a Smart View app uninstall/reinstall on the tablet hasn't worked either - then it would be best to reach out to the Support folks in the US for any advice they may have.


Prince_Community_Sig03.jpg

 Say "Hello!" to the Community in The Introduce Yourself Thread.


New Member

It works with the Microsoft wireless Display Adapter using thr Smart View app.

New Member

I know this is an old thread but i have been attempting this and not having success. Smart View sees my wicrosoft display adapter, while connecting the tv says it is connecting to my tablet, flashes 4 or 5 times then stops.

I have Chromecast, the MS display adapter as well as a display link supported device. I can get none of them to mirror successfully. Casting works for appropriate supported apps but i want to mirror my screen. My goal is to use a drawing program and be able to view on a larger screen.

GALAXY TAB S3

Panasonic 1920x1080p Plasma TV

I am able to mirror my surface tablet (surface pro 3) to tv fine so believe it has nothing to do with wireless connections etc.

Its behaving like a resolution match problem and i can find no way on Tab S3 to change its display resolution.

Has anyone actually solved this problem and got it working?

New Member

Bumping this.

 

Has anyone had success with Anycast Dongle M2? Trying to mirror from netflix using a DNS service.

Top Liked Authors