Support

Open search

Unable to install firmware via usb

Apprentice

I have a Samsung 4K UHD TV (UE55RU7100KXXU).

 

I have downloaded the latest minor update and I do exactly as instructed. The usb stick is as it should be, according to the instructions. I put it in the USB slot, go to software update but it doesn't give me the option to update via the USB. It did before but now it seems I can only do it OTA.

 

Any ideas how I can update over USB without reseting the whole TV back to 'factory settings'?

 

Pb

2 REPLIES 2
ChrisM Moderator
Moderator

Hi @Pantyboy 

 

Did you extract the file before dowloading it to your USB stick? Also, what's the current software version on your TV? Go to Home > Settings > Support > About This TV.

Apprentice
Hi @ChrisM.
Please accept my apologies for taking so long to reply.
We tried again last evening and it asked if we wanted to download from a USB stick. However, I didn't have one ready and so it hasn't appeared since.
We did check the details as you've suggested and it looks as thought the lastest version is now installed (1062.1), so it hase already solved this problem without me realising it but it hasn't resolved my previous problem and a new one which has raised its head.
I'm begining to regret buying this bloody TV.
Top Liked Authors